Results 1 to 4 of 4
  1. #1

    Default RX65 range problem?

    Just drove by a motorcycle officer, with a constant Ka, going in the opposite direction on a flat surface, about 40ft of grass median between us. As he passed me my RX65 did not show a full meter reading, only about 3 or 4.

    Is there something wrong with my RX65 or is this normal? In my previous post I also stated that my RX65 did not show a full meter when I drove by a "YOUR SPEED" display drone, K-band...

    Is this normal?

  2. #2
    Power User
    Join Date
    Jan 2005


    Bels have a problem with their ramp up so this is normal.

  3. #3
    Join Date
    Mar 2006


    Some people RX65s have a ramp up problem.My best advice to you is if your RX65 alerts you even if the signal seems weak on the display,just slow down.

  4. #4


    Thanks for the info guys. I guess I just have to be more careful, even with single bar alerts.



Similar Threads

  1. XR-950 AUNZ (v995) detection range problem
    By Anthrax in forum Beltronics
    Replies: 3
    Last Post: 04-23-2008, 03:41 PM
  2. Rx65 and POP problem
    By Crashin in forum Beltronics
    Replies: 2
    Last Post: 10-25-2007, 02:19 PM
  3. Bel RX65 pro problem
    By siongchuang in forum Beltronics
    Replies: 9
    Last Post: 10-24-2007, 10:27 PM
  4. Bel RX65 problem
    By JordanDawg05 in forum Beltronics
    Replies: 6
    Last Post: 05-21-2007, 09:48 PM
  5. x50 range problem
    By ramil in forum Escort
    Replies: 17
    Last Post: 06-26-2006, 11:43 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts