Page 1 of 2 12 LastLast
Results 1 to 10 of 17
  1. #1

    Default RX65 Pro mounting issues

    I have recently purchased this detector and seems like the windshield mount is really bad, the detector keeps on falling down all the time. The little metal tab that goes into the cavity on top of the detector does not seem to be a snug fit when the adjusting button is released. The detector is also positioned so the upper edge rests against the windshield as advised. I have stopped using it after it has fallen 7-8 times. Help!!!

    I broke down and ordered the visor mount from Ebay yesterday, but am unsure how that would help me.

    Any help appreciated.

    Thanks!

  2. #2
    Speed Demon
    Join Date
    Mar 2005
    Location
    Baltimore, MD
    Posts
    771

    Default

    Where are you mounting the detector? I've had trouble with mounting my X50 on the little dots above my rearview--it will fall from there. Mounted directly to the glass it does well. Just make sure to wet the suction cups real good and stick it on. Position it to where you want and remove the RD--that will allow the suction cups to 'set up'. Should be pretty solid by then.

    The X50 bounces a bit on the mount so not surprised your RX65 does the same. Just keep it far forward on the mount and you're good to go.

    Welcome to the forums! And if you need more accessories, don't forget to check http://www.radarbusters.com

  3. #3
    Radar Fanatic
    Join Date
    Nov 2004
    Location
    Kentucky, USA
    Posts
    2,303

    Default

    Make sure that the suction cups and windshield are completely clean, and push the suction cups really hard. They will normally make a little pop sound when they're on good.

  4. #4
    Newcomer
    Join Date
    Jul 2005
    Location
    Fort Worth Texas
    Posts
    21

    Default

    Clean the mounting area on the windshield and the cups with Isopropyl alcohol. Works wonders on old cups. My old whistler 1748 mount started falling, cleaning remedied the problem.

    David. :-)

  5. #5
    Newcomer
    Join Date
    Jul 2005
    Location
    Fort Worth Texas
    Posts
    21

    Default

    vtec29k

    Off topic question? How do like your Honda CRV AWD???
    I have a Ford Escape. I did consider the Honda CRV.

    David out.

  6. #6
    Administrator
    Join Date
    Nov 2004
    Location
    Morristown, Arizona, United States
    Posts
    3,300

    Default Vasoline

    I have found that putting Vasoline on old cups also helps
    RadarBusters.com
    Motorcycle Mounts and Accessories
    Also Join me at -
    Twitter: RadarRoy
    Facebook: Roy Reyer

  7. #7
    Newcomer
    Join Date
    Jul 2005
    Location
    Fort Worth Texas
    Posts
    21

    Default

    RadarRoy,

    How the heck did you think of using Vasoline, are you serious??

    David out.

  8. #8
    Power User
    Join Date
    Feb 2005
    Location
    In Car RamRod
    Posts
    4,001

    Default

    Quote Originally Posted by David
    RadarRoy,

    How the heck did you think of using Vasoline, are you serious??

    David out.
    On one of those lonely nights at home...vasoline near by

  9. #9
    Yoda of Radar
    Join Date
    Dec 2004
    Location
    In front of my computer
    Posts
    10,773

    Default

    Wow Vaseline really works well on the cups! Just leaves a bit too much stuff on the windscreen though.

  10. #10
    Power User
    Join Date
    Feb 2005
    Location
    In Car RamRod
    Posts
    4,001

    Default

    Quote Originally Posted by SmaartAasSaabr
    Wow Vaseline really works well on the cups! Just leaves a bit too much stuff on the windscreen though.
    Im not even going to touch that one

 

 

Similar Threads

  1. Beltronics RX65 issues, need help
    By mrphotoman in forum Beltronics
    Replies: 4
    Last Post: 03-29-2011, 05:13 PM
  2. V1 Mounting Issues in BMW Z4
    By tnharley in forum Valentine One
    Replies: 8
    Last Post: 01-02-2008, 08:01 PM
  3. LPP Mounting Issues
    By jfriedman8 in forum Laser Jammers - General
    Replies: 12
    Last Post: 12-18-2007, 04:03 PM
  4. Issues With Power Switch on RX65
    By Retaliation in forum Beltronics
    Replies: 8
    Last Post: 10-30-2007, 12:15 PM
  5. Another RX65 with issues/Buy from Roy
    By Studdg in forum Beltronics
    Replies: 18
    Last Post: 12-13-2006, 03:03 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •