Page 1 of 3 123 LastLast
Results 1 to 10 of 26
  1. #1
    Newcomer
    Join Date
    Sep 2005
    Posts
    12

    Default Newbie with a Bel 985 Quick Question

    hello everyone , i've had my 985 for a couple years now and just last week it stopped making sounds. I've tried adjusting the volume with no luck. The detector still works great but doesn't make a sound, at all, never. I plan on buying a new detector, but i wanted to wait another year. Is this common? Is it fixable? Any help would greatly be appreciated, thanks in advance.

  2. #2
    Lead Foot
    Join Date
    Jul 2005
    Location
    K-55 land
    Posts
    414

    Default

    My thoughts:

    no sound---->probably speaker
    severely distorted sound--""
    up really close, ear to speaker--phhht,phhht,phhhht sound---->SMD resistors.

    Search for my username and you'll find description on how to open case.


    HTH
    --b

  3. #3
    Newcomer
    Join Date
    Sep 2005
    Posts
    12

    Default .......

    no sound at all, i tried searching under your username, and it came up with 5 or 6 topics. However i didn't see anything pertaining to this problem. What am i doing wrong? Can you provide me with the web address??

  4. #4
    Power User
    Join Date
    Feb 2005
    Location
    In Car RamRod
    Posts
    4,001

    Default

    I had the exact same problem, turned out the speaker was dead, sent it off to Bel and new speaker and worked a treat.

  5. #5
    Newcomer
    Join Date
    Sep 2005
    Posts
    12

    Default .......

    i was wrong, the speaker must be shot because i can hear it if i put my ear right up to it, What are my options?? If my only option is to send it off to bel, is it worth the $$?? If there is a way to just replace the speaker, how?? Any help would greatly be appreciated..

  6. #6
    Yoda of Radar
    Join Date
    Dec 2004
    Location
    In front of my computer
    Posts
    10,773

    Default

    Step 1 : Open unit

    Step 2 : Identify size / type of speaker, try to find if you've got a similar piece lying around somewhere,

    Step 3 : If not, put the unit back together, minus speaker, and drive down to the local electronics surplus store for a replacement speaker

    Step 4 : Reopen the case, solder in the new speaker

    Step 5 : Apply power to the unit and see if it alerts properly. Enjoy your detector.

    If you're not comfortable with that I could probably do the whole thing for a lot less than $85...

  7. #7
    Newcomer
    Join Date
    Sep 2005
    Posts
    12

    Default .....

    Ok i'm sorry i'm so dumb, but what would u suggest is the same size and type that i may having lying around the house (i have the bel 985)?? Also if i don't have it lying around, do you think an car audio store would have it??

    thanks in advance

  8. #8
    Yoda of Radar
    Join Date
    Dec 2004
    Location
    In front of my computer
    Posts
    10,773

    Default

    Maybe but you'd be better off finding a electronics store, you know like those ones that are a shack filled with old resistors and speakers and stuff... Not like a Radio Shack or whatever...

    I don't know what you'd have that is the proper size and spec, but I'd be thinking like an old small device of some sort...

    hey you have a Trans AM? I have a Firebird, 1976 with the 400.

  9. #9
    Newcomer
    Join Date
    Sep 2005
    Posts
    12

    Default .........

    yeah, i have an 88 gta 350, red.

    i just suck with car audio stuff, and that obviously includes speakers of any sort.
    I guess i'll start looking around, how about a speaker off a set of headphones?? If not i'll try an car electronics store tomorrow.

  10. #10
    Power User
    Join Date
    Nov 2004
    Location
    Maryland
    Posts
    3,939

    Default

    Does the 985 have an earpiece jack? If it does, maybe an easy fix would be plug a speaker into it.

 

 

Similar Threads

  1. Quick Question
    By doddy37 in forum Radar Detectors - General
    Replies: 2
    Last Post: 01-30-2009, 06:16 PM
  2. Quick question..newbie
    By murphy in forum Escort
    Replies: 0
    Last Post: 11-15-2008, 01:12 PM
  3. Quick question from a newbie..
    By bull8t in forum Radar Detectors - General
    Replies: 7
    Last Post: 09-07-2007, 10:52 PM
  4. Quick Question.....
    By PutterPlace2 in forum Cobra
    Replies: 4
    Last Post: 04-19-2007, 12:10 PM
  5. Quick question on Ka IO w/ X50
    By ELVATO in forum Escort
    Replies: 5
    Last Post: 04-02-2007, 01:33 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •