Results 1 to 10 of 10
  1. #1
    Radar Fanatic
    Join Date
    Jan 2008
    Location
    Nebraska
    Posts
    2,216

    Default 955 possibly dead

    As I'm driving home tonight with the 955, staying 20 below psl because of all the stupid f***s who feel the need to drive so slow after just 4" of snowfall, and the roads being plowed perfectly clear, I catch a glimpse of the 955s display suddenly going blank. Look down at smartcord, power light is off and I check that the plug is secure in the cig lighter. It is. I hit the power button on the RD and hear the usual clicking noise and both red/green lights illuminate on the smartcord as long as the power button is held in, but RD won't power on. I try again a minute later and it powers up, but not for long. I come home and try to power it up again, nothing; the reset combination won't boot it up, and for some reason I tried the tutorial mode combination and still nothing.

    Swapped it out with the X50, which is working fine so its not a wiring/fuse issue.

    I have couple of days to see if it wants to behave or Bel gets a call Monday. I was considering sending it in for a checkup and a case/lens replacement last June after it was subjected to the heat and smoke from the house fire, but strangely its had better performance than before the fire and it consistently beats my X50 which is why I've been using the 955 almost exclusively.

  2. #2
    Radar Fanatic
    Join Date
    Jul 2008
    Location
    Nashville, TN
    Posts
    2,309

    Default Re: 955 possibly dead

    Quote Originally Posted by dpatel01 View Post
    As I'm driving home tonight with the 955, staying 20 below psl because of all the stupid f***s who feel the need to drive so slow after just 4" of snowfall, and the roads being plowed perfectly clear, I catch a glimpse of the 955s display suddenly going blank. Look down at smartcord, power light is off and I check that the plug is secure in the cig lighter. It is. I hit the power button on the RD and hear the usual clicking noise and both red/green lights illuminate on the smartcord as long as the power button is held in, but RD won't power on. I try again a minute later and it powers up, but not for long. I come home and try to power it up again, nothing; the reset combination won't boot it up, and for some reason I tried the tutorial mode combination and still nothing.

    Swapped it out with the X50, which is working fine so its not a wiring/fuse issue.

    I have couple of days to see if it wants to behave or Bel gets a call Monday. I was considering sending it in for a checkup and a case/lens replacement last June after it was subjected to the heat and smoke from the house fire, but strangely its had better performance than before the fire and it consistently beats my X50 which is why I've been using the 955 almost exclusively.
    How old is the 955?

    Oh and we haven't gotten 4" of snow all winter. Its been a sucky, cold, damp winter down here. Not snowy though.

  3. #3
    Radar Fanatic
    Join Date
    Jan 2008
    Location
    Nebraska
    Posts
    2,216

    Default Re: 955 possibly dead

    build date Feb '07, purchased June '07.

    went for repair around Jan '08, got the extended warranty on it too at the time.

  4. #4
    Experienced
    Join Date
    Jun 2006
    Location
    Ellicott City, Maryland
    Posts
    243

    Default Re: 955 possibly dead

    Maybe try another power cord, that could be an issue.

    Michael

  5. #5
    Yoda of Radar
    Join Date
    Oct 2007
    Location
    Los Angeles Area
    Posts
    13,881

    Default Re: 955 possibly dead

    Quote Originally Posted by declansdad View Post
    Maybe try another power cord, that could be an issue.

    Michael
    This is what I was thinking also.

  6. #6
    Radar Fanatic
    Join Date
    Nov 2008
    Posts
    1,764

    Default Re: 955 possibly dead

    I had a vector go bad from getting too hot on a long trip one time. It just died. I went out and bought a new one for the return trip and when I got home the original one started working fine again. If yours has been working better than your x50 I would send it in for IRAN. It sounds like a good one worth fixing.

  7. #7
    Radar Fanatic
    Join Date
    Jan 2008
    Location
    Nebraska
    Posts
    2,216

    Default Re: 955 possibly dead

    The RD powered on yesterday and I've had two days to do some testing. It doesnt seem as sensitive w/regards to its normal falses but there could be other factors involved such as humidity that effect performance so I won't give a conclusive answer as to whether or not its needs to be serviced. I didn't want to take any chances on a trip today so I used the 8500 and got hit with I/O 35.5 Ka from a state trooper, which was the main area where my 955 really shined over the 8500, but it was also my fault for not using a rabbit on the return trip. Sh!t happens, and I'm not here to b!tch about what I got tonight.

  8. #8
    Professional
    Join Date
    Feb 2006
    Location
    Richmond, Virginia
    Posts
    1,398

    Default Re: 955 possibly dead

    So I guess that you got a ticket.

  9. #9
    Radar Fanatic
    Join Date
    Jan 2008
    Location
    Nebraska
    Posts
    2,216

    Default Re: 955 possibly dead

    Quote Originally Posted by asianfire View Post
    So I guess that you got a ticket.
    Yes

  10. #10
    Radar Fanatic
    Join Date
    Nov 2008
    Posts
    1,764

    Default Re: 955 possibly dead

    I guess you will be sending in the 955? It sounds like it would be worth it.

 

 

Similar Threads

  1. Could it possibly...
    By aBLTcheeseburger in forum Whistler
    Replies: 15
    Last Post: 04-18-2010, 06:40 PM
  2. could I possibly have the stealthiest car on here.
    By 06blackgto in forum Show off your install.
    Replies: 41
    Last Post: 11-24-2008, 09:51 AM
  3. Replies: 5
    Last Post: 12-08-2006, 03:58 PM
  4. What could a used V1 possibly be worth ?
    By nomore55 in forum Valentine One
    Replies: 17
    Last Post: 06-15-2005, 11:58 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •