Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1
    Newcomer
    Join Date
    Jun 2008
    Location
    Chicago, Illinois, United States
    Posts
    30

    Default STI-R Plus filtering out K band incorrectly?

    Hi. Well I've got my sti driver and my sti-r plus next to each other in the window to compare how they are doing. The area i live at leave Ka on and K as well. Problem is that K band is not going off on some cops. Also there were 3 cops that went by and the sti-r plus said stored while the driver was blaring K band. Anyway to fix this?

    Also the Driver will find Ka band sometimes on the interstate but not the Plus. Could this be the false Kas from Cobra owners? Does the Plus filter this as well?

  2. #2
    Old Timer
    Join Date
    Jun 2005
    Location
    New Hampshire
    Posts
    6,833

    Default Re: STI-R Plus filtering out K band incorrectly?

    Quote Originally Posted by Fezzik View Post
    Hi. Well I've got my sti driver and my sti-r plus next to each other in the window to compare how they are doing. The area i live at leave Ka on and K as well. Problem is that K band is not going off on some cops. Also there were 3 cops that went by and the sti-r plus said stored while the driver was blaring K band. Anyway to fix this?
    Turn off auto-lock.
    Also the Driver will find Ka band sometimes on the interstate but not the Plus. Could this be the false Kas from Cobra owners? Does the Plus filter this as well?
    If RDR is on or you use the Ka band segmentation feature, it may filter out Ka falses (or actual LEOs if you turn off the wrong segments) more than the STi Driver.
    If I'm passing you on the right, YOU are in the wrong lane!

    If speed kills, how come I'm still alive?

    Active Countermeasures: V1 3.858, Escort Redline, Beltronics STi-R+, LI Dual 7.1x CPU/8.7 Heads (front)
    Other/Backup Countermeasures: V1 3.813 (loaned to friend), Beltronics Pro RX65 M4 6.3
    Vehicle: 2002 Audi A4 1.8T Quattro
    LEO Toys: Kustom Pro Laser II & III
    Encounters/Saves August 2011: Radar 3/1, Laser 0/0


  3. #3
    Old Timer
    Join Date
    Jun 2007
    Posts
    9,405

    Default Re: STI-R Plus filtering out K band incorrectly?

    Quote Originally Posted by kpatz View Post
    Quote Originally Posted by Fezzik View Post
    Hi. Well I've got my sti driver and my sti-r plus next to each other in the window to compare how they are doing. The area i live at leave Ka on and K as well. Problem is that K band is not going off on some cops. Also there were 3 cops that went by and the sti-r plus said stored while the driver was blaring K band. Anyway to fix this?
    Turn off auto-lock.
    Also the Driver will find Ka band sometimes on the interstate but not the Plus. Could this be the false Kas from Cobra owners? Does the Plus filter this as well?
    If RDR is on or you use the Ka band segmentation feature, it may filter out Ka falses (or actual LEOs if you turn off the wrong segments) more than the STi Driver.
    X2, it should also unlearn the signals it stored if the signal is no longer at that location.
    9500CI - LI Dual - ALP - MAX - RedLine - V1 3.872, 3.893 YaV1 {1,7,b,E,F,G (l/L)} - 9500I Blue=x1 upgraded to ix. - 9500I Red=x2 - 8500 x1.

    9500I/ix Thread & TrueLock info:http://www.radardetector.net/forums/escort/26868-explanation-9500i-truelock-info-tricks.html

    V1 review & options/settings to quiet it down. (manual programming): http://www.rdforum.org/showthread.php?t=105

    My install:
    http://www.rdforum.org/showthread.php?t=37598

    -No one detector is perfect for everyone. And the one you donít like may be perfect for someone else.

    RDFGS: http://www.rdforum.org/wiki/index.ph...aphical_Survey

  4. #4
    Newcomer
    Join Date
    Jun 2008
    Location
    Chicago, Illinois, United States
    Posts
    30

    Default Re: STI-R Plus filtering out K band incorrectly?

    Thanks. Will turning autolock off unlearn the spots its done this too?

    is there specific freq that the cobra's leak out the Ka?
    Thanks!

  5. #5
    Old Timer
    Join Date
    Jun 2005
    Location
    New Hampshire
    Posts
    6,833

    Default Re: STI-R Plus filtering out K band incorrectly?

    Actually, if you drive through that area again and there's no radar there, it should "unlearn" that location automatically. At least that's how the 9500ci works. I don't have an STi-R+ manual handy.

    Cobras usually leak around the 33.6 GHz range. Turning off Ka segment 1 should minimize most Cobra falses. Many people run with just segments 2, 5, 8 on, which covers the 3 main frequencies that Ka radar guns in North America use.

    Also, if it happens again (a signal gets locked out accidentally), just hold the MUTE button down for a few seconds to unlock the signal.

    Are you running either of your units in "Tech" mode (frequency display)? Then you'll know what Ka frequencies you're seeing, both for LEOs and falses.
    Last edited by kpatz; 04-05-2011 at 01:45 PM.
    If I'm passing you on the right, YOU are in the wrong lane!

    If speed kills, how come I'm still alive?

    Active Countermeasures: V1 3.858, Escort Redline, Beltronics STi-R+, LI Dual 7.1x CPU/8.7 Heads (front)
    Other/Backup Countermeasures: V1 3.813 (loaned to friend), Beltronics Pro RX65 M4 6.3
    Vehicle: 2002 Audi A4 1.8T Quattro
    LEO Toys: Kustom Pro Laser II & III
    Encounters/Saves August 2011: Radar 3/1, Laser 0/0


  6. #6
    Old Timer
    Join Date
    Jun 2007
    Posts
    9,405

    Default Re: STI-R Plus filtering out K band incorrectly?

    Note: it takes about ~6 passes with no signal present to unlock a signal automatically and you need to be over ~35mph.
    9500CI - LI Dual - ALP - MAX - RedLine - V1 3.872, 3.893 YaV1 {1,7,b,E,F,G (l/L)} - 9500I Blue=x1 upgraded to ix. - 9500I Red=x2 - 8500 x1.

    9500I/ix Thread & TrueLock info:http://www.radardetector.net/forums/escort/26868-explanation-9500i-truelock-info-tricks.html

    V1 review & options/settings to quiet it down. (manual programming): http://www.rdforum.org/showthread.php?t=105

    My install:
    http://www.rdforum.org/showthread.php?t=37598

    -No one detector is perfect for everyone. And the one you donít like may be perfect for someone else.

    RDFGS: http://www.rdforum.org/wiki/index.ph...aphical_Survey

  7. #7
    Newcomer
    Join Date
    Jun 2008
    Location
    Chicago, Illinois, United States
    Posts
    30

    Default Re: STI-R Plus filtering out K band incorrectly?

    Quote Originally Posted by kpatz View Post
    Actually, if you drive through that area again and there's no radar there, it should "unlearn" that location automatically. At least that's how the 9500ci works. I don't have an STi-R+ manual handy.

    Cobras usually leak around the 33.6 GHz range. Turning off Ka segment 1 should minimize most Cobra falses. Many people run with just segments 2, 5, 8 on, which covers the 3 main frequencies that Ka radar guns in North America use.

    Also, if it happens again (a signal gets locked out accidentally), just hold the MUTE button down for a few seconds to unlock the signal.

    Are you running either of your units in "Tech" mode (frequency display)? Then you'll know what Ka frequencies you're seeing, both for LEOs and falses.
    This is great info thanks!

    Great info also from everyone else. I'm just a little paranoid b/c the cops have someone pulled over every day here and its dishearting to see that the plus did give me a K.

  8. #8
    Professional
    Join Date
    Aug 2009
    Posts
    1,148

    Default Re: STI-R Plus filtering out K band incorrectly?

    You said the two detectors where right next to each other, how close exactly? Keep in mind that even though these detectors are stealth at very close range they do emitt RF and could be interfering with each other.

  9. #9
    Newcomer
    Join Date
    Jun 2008
    Location
    Chicago, Illinois, United States
    Posts
    30

    Default Re: STI-R Plus filtering out K band incorrectly?

    I'm positive it's not them throwing each other off. The k bands went off as each cop came over the hill and turned onto the street i was on.

  10. #10
    Old Timer
    Join Date
    Jun 2007
    Posts
    9,405

    Default Re: STI-R Plus filtering out K band incorrectly?

    Quote Originally Posted by Fezzik View Post
    I'm positive it's not them throwing each other off. The k bands went off as each cop came over the hill and turned onto the street i was on.
    Thats not necessarily the case, with close mounting (within a foot or so) there can be regular EMI emissions that can cause one to not alert appropriately while the other is fine. Most likely antenna to get interference would be the Plus antenna.
    9500CI - LI Dual - ALP - MAX - RedLine - V1 3.872, 3.893 YaV1 {1,7,b,E,F,G (l/L)} - 9500I Blue=x1 upgraded to ix. - 9500I Red=x2 - 8500 x1.

    9500I/ix Thread & TrueLock info:http://www.radardetector.net/forums/escort/26868-explanation-9500i-truelock-info-tricks.html

    V1 review & options/settings to quiet it down. (manual programming): http://www.rdforum.org/showthread.php?t=105

    My install:
    http://www.rdforum.org/showthread.php?t=37598

    -No one detector is perfect for everyone. And the one you donít like may be perfect for someone else.

    RDFGS: http://www.rdforum.org/wiki/index.ph...aphical_Survey

 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 1
    Last Post: 04-06-2010, 09:33 AM
  2. Replies: 15
    Last Post: 08-29-2007, 01:03 PM
  3. Just got a Bel 895, K band filtering?
    By nautica2o3 in forum Beltronics
    Replies: 5
    Last Post: 01-30-2007, 11:21 AM
  4. Valentine filtering K-band?
    By Veri in forum Valentine One
    Replies: 4
    Last Post: 07-04-2005, 12:43 AM
  5. Cop Running Radar Incorrectly?
    By Surgeon in forum Radar Detectors - General
    Replies: 6
    Last Post: 05-23-2005, 01:39 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •