Results 1 to 7 of 7

Thread: STIR+ problem!

  1. #1
    Good Citizen
    Join Date
    Jun 2008
    Location
    Utah
    Posts
    182

    Default STIR+ problem!

    Been using my STIR+ for a while and loved it, however for the last week or so its been acting up. Each time I start the car and begin driving I immediately get a K2 and Ka2 regardless of location. After driving about 50 yards it will go away, but if I stop it comes back occasionally. Each time I cycle (turn off completely) it will act the same way. I also can't get the K alert at Walgreens or Walmart. Ideas??

  2. #2
    Mobile Installer
    Join Date
    Jul 2007
    Location
    East Coast (USA)
    Posts
    4,203

    Default Re: STIR+ problem!

    Try a factory reset on the unit. If that does not work send it in for a tuneup.
    Radarrob is a approved radar detector and Parking sensor installer Anywhere in the United States.Has access to Radar and Lidar Guns to test systems.Need Help Choosing a Radar Detector or parking sensor for your needs? Visit my Install Thread:

    http://www.radardetector.net/forums/...installer.html




    "I'm interested to see how well you do.I never seen a car JTG before would be a first for me.."

  3. #3
    Good Citizen
    Join Date
    Jun 2008
    Location
    Utah
    Posts
    182

    Default Re: STIR+ problem!

    I completed the reset, downloaded tools and re-enabled the detector. Now I can't get it false at known locations (Walmart, Walgreens etc) but I did have a K1 while driving on the freeway.
    This leads me to believe the detector is working, but maybe not always. Tune up???

  4. #4
    Speed Demon
    Join Date
    Apr 2012
    Location
    Amerika
    Posts
    684

    Default Re: STIR+ problem!

    Quote Originally Posted by Stilldrivin View Post
    I completed the reset, downloaded tools and re-enabled the detector. Now I can't get it false at known locations (Walmart, Walgreens etc) but I did have a K1 while driving on the freeway.
    This leads me to believe the detector is working, but maybe not always. Tune up???
    Yep, sounds like it's sick. Time to make an appointment w/ the Dr. to heal the patient.

  5. #5
    Good Citizen
    Join Date
    Jun 2008
    Location
    Utah
    Posts
    182

    Angry Re: STIR+ problem!

    Unfortunately, bad detector.
    Sent the receiver into Bel/Escort and now I am beinginformed that the receiver had “moisture” damage. Translation: New detectorrequired with $$$ out of pocket.
    Now I am stuck. Do I pay the $400 to get a new receiver, orattempt to liquidate remaining assets of STRI+ and snag a new detector like theMax2 or others.

    Thoughts? I know youcan’t offer to sell here, is there somewhere that this forum recommends?


  6. #6
    Administrator
    Join Date
    Nov 2004
    Location
    Morristown, Arizona, United States
    Posts
    3,300

    Default Re: STIR+ problem!

    You're more then welcome to try to sell it here as parts and look at getting a new detector
    RadarBusters.com
    Motorcycle Mounts and Accessories
    Also Join me at -
    Twitter: RadarRoy
    Facebook: Roy Reyer

  7. #7
    Good Citizen
    Join Date
    Jun 2008
    Location
    Utah
    Posts
    182

    Default Re: STIR+ problem!

    Quote Originally Posted by Radar Roy View Post
    You're more then welcome to try to sell it here as parts and look at getting a new detector
    I thought the forum didn't allow any selling of products!?

    Thanks the response Roy!

 

 

Similar Threads

  1. STiR+ Update Problem - Help!
    By ToySoldier in forum Beltronics
    Replies: 5
    Last Post: 08-18-2015, 05:19 AM
  2. Max and Stir+ together
    By bryanj0308 in forum Escort
    Replies: 2
    Last Post: 07-29-2013, 08:33 PM
  3. Replies: 6
    Last Post: 02-02-2011, 02:57 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •