Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1

    Default Mercedes E320 Affects Radar!

    I have a 1999 E320 in which my radar (passport 8500) gives off intermittent false alerts in kh band and laser. Other cars no problem. Does anyone know of why this could occur? No satellite radio or GPS devices in use while this is happening, and Mercedes denies anything unusual in the 320 that could make this happen.

    Carl

  2. #2
    Administrator
    Join Date
    Nov 2004
    Location
    Morristown, Arizona, United States
    Posts
    3,300

    Default Crash Avoidance

    gives off intermittent false alerts
    Does it have one of those crash avoidance systems in it??
    Don't know much about them, but I understand that they use some type of RF
    RadarBusters.com
    Motorcycle Mounts and Accessories
    Also Join me at -
    Twitter: RadarRoy
    Facebook: Roy Reyer

  3. #3
    Yoda of Radar
    Join Date
    Dec 2004
    Location
    In front of my computer
    Posts
    10,773

    Default

    Any power loads going on at the same time? Honking horn, turn signals, acceleration, deceleration...

  4. #4

    Default

    Nope, no crash avoidance system. Radar will go off while cruising at constant speed on the freeway. It loves to just blast a full kh reading or a laser reading out of nowhere, causing me to unplug it from the lighter and fling it. Very unnerving. I emailed a mercedes service manager and he doesn't have a clue. I have some other reseach possibilities in mind. My old 1986 300 E wasn't a problem, just the 1999 E320. I'm wondering if any other cars experience this problem?

    Ag

  5. #5
    Radar Fanatic
    Join Date
    Jul 2005
    Location
    ATLANTA. Im never leaving.
    Posts
    2,418

    Default

    occasionally (1 out of 4 or so times) when i start my car mine will go off on X band. i have no i dea either.

  6. #6
    Radar Fanatic
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    2,357

    Default

    My girlfriend's mom has a '99 E300 Turbodiesel and a V1 1.7 that work very well together. I don't think it's likely to be the car. Though I haven't had consistent laser falsing I did have a problem with X-band falsing early this summer that turned out to be my cell phone charger. That was a hard one to figure out because it only happens when my phone is charging andturned off. I was on the phone with VR thinking that it was screwed up but eventually traced it.

    Airport radar has been known to set off some radar detectors, particular the RX65, on laser. Jimbonnz theorized that the radar interferes with the laser sensor itself to give a false signal.

    Particularly relevant to you is the fact that the original Passport 8500 is known to be sensitive to electrical noise. A classic example is a user honking the horn and immediately getting a laser false. Some have the same problem when accelerating at WOT. My understanding of that one is that they solved the problem for the X50 by adding a capacitor to the power plug that damps out the low-level noise.

    Important question: How frequent is it that you see the falsing? Once a day? Once every hour? Once every minute?

  7. #7

    Default

    It happens sporadically, sometimes nothing for a day or two and then constantly every minute on the minute. About 30% of the falses are laser the rest KA. I've tried the radar in my wife's car and it works fine.

    Ag

  8. #8
    Scratonicity Groupie
    Join Date
    Mar 2005
    Posts
    7,614

    Default

    its your alternator starting to go bad. when I was borrowing my friends truck for a few days I was running my x50 at the time. And I kept getting laser alerts like crazy. Over time his battery stopped charging, and when he swapped his altenator never got another false alert!

  9. #9
    Professional
    Join Date
    May 2005
    Posts
    992

    Default

    I had this problem happen in my work van many times where Laser would false constantly. I noticed every time I punched the gas pedal it went off or anything that actually accelerated. It tends to go off above 30mph as well.

  10. #10
    Radar Fanatic
    Join Date
    Jul 2005
    Location
    ATLANTA. Im never leaving.
    Posts
    2,418

    Default

    Quote Originally Posted by ZO6Vette
    I had this problem happen in my work van many times where Laser would false constantly. I noticed every time I punched the gas pedal it went off or anything that actually accelerated. It tends to go off above 30mph as well.
    mine does the same sh*!. i found when i put down a window or open up my vents (expos and navi's), or hit the gas, or turn my subs up that it would laser false. very very annoying . seemed like anything that took any power away from it would make it false. i wish i could find out if im getting a new car or not cuz i want to hardwire it.

 

 

Similar Threads

  1. What affects radar signals?
    By partsfreak in forum Radar Detectors - General
    Replies: 2
    Last Post: 01-15-2009, 10:04 PM
  2. So Rear K mute affects ALL modes?
    By jdong in forum Valentine One
    Replies: 8
    Last Post: 12-23-2007, 07:16 PM
  3. Affects of paint on Radar?
    By GET 1T DONE in forum Radar Detectors - General
    Replies: 13
    Last Post: 09-19-2007, 06:48 PM
  4. Jammer's affects on red light camera's?
    By SpeedyCelica in forum Laser Jammers - General
    Replies: 3
    Last Post: 10-03-2006, 02:26 PM
  5. The affects of fog on radar detection...
    By laserblaster in forum Radar Detectors - General
    Replies: 0
    Last Post: 11-21-2005, 06:37 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •