Page 1 of 3 123 LastLast
Results 1 to 10 of 29
  1. #1
    Speed Demon
    Join Date
    May 2005
    Location
    Washington
    Posts
    632

    Default V1 Price and Firefox

    Hello everyone,

    I have two questions, one being does anyone know of where you can get a v1 under 400 dollars (and when maybe the next upgrade would be), and my second does anyone know why firefox doesnt work with the boards here? (I can browse, but cant post or any of the little buttons/pictures/smilies I also have BBcode plugin installed for it too.)

    Thanks for any help guys

  2. #2
    Banned
    Join Date
    Mar 2005
    Location
    Seattle
    Posts
    2,854

    Default

    It's against policy to put links on this board to any website that sells radar detectors, other then radarbusters.com.

    On another note I'd wait and purchase the V1 when they fix the "j" bug.

    Chris

  3. #3
    Advanced Member
    Join Date
    Feb 2005
    Location
    Southern MA
    Posts
    10,127

    Default

    You could buy a V1 off an auction site but after you pay for the upgrade cost you would of most likely paid more than if you ought the detector from V! directly....Your best bet and cheapest would be going to the licenced retail to buy

    Spoiler: show

    Radar Detectors-V1 & BEL v995
    Laser Jammer-Laser Interceptor Quad
    GPS Camera Locator-Cheetah C100
    GPS Nav-Garmin nuvi w/Trapster
    CB Radio-Galaxy DX-949 w/Wilson 500
    Scanner-RS Pro-96

  4. #4
    Good Citizen
    Join Date
    May 2005
    Posts
    75

    Default

    JTW,

    I think you contribute an exceptional amount to this site, and I applaud your efforts. I mention this because I don't want to be percieved as picking a fight. However I feel that I would be remiss not to point out one simple point...


    The J function seems to work perfectly well in the V-1 that I own. I understand that I have not yet faced every situation, but it has consistently worked as advertised for me.

    I find the criticism of this feature to be unwarranted.

  5. #5
    Banned
    Join Date
    Mar 2005
    Location
    Seattle
    Posts
    2,854

    Default

    Quote Originally Posted by ArtistZ
    JTW,

    I think you contribute an exceptional amount to this site, and I applaud your efforts. I mention this because I don't want to be percieved as picking a fight. However I feel that I would be remiss not to point out one simple point...


    The J function seems to work perfectly well in the V-1 that I own. I understand that I have not yet faced every situation, but it has consistently worked as advertised for me.

    I find the criticism of this feature to be unwarranted.
    Thank you for brining up your point of view Artist. If you see a different point of view I would expect you to bring it up because I can sometimes open my mouth without thinking first :wink: . I pointeded this out because Valentine Research allegedly confirmed they knew about the glitch when other members on the forum called them.

    If an X50 owner was running off at the mouth about the "j" function I wouldn't have given the comments any weight, but since the owners were V1 guys I didn't think they would lie about it.

    Chris

  6. #6
    Banned
    Join Date
    Mar 2005
    Location
    Seattle
    Posts
    2,854

    Default

    To read more about other peoples experiences with the "J bug" go to this thread.

    http://www.radardetector.net/%26quot...V-1.-1444t.php

    Chris

  7. #7
    Banned
    Join Date
    May 2005
    Location
    Fort Rucker, Alabama
    Posts
    22

    Default I'm running Firefox

    I am running firefox on this machine, and it works great for this and all sites. Maybe check your security settings.

    I bought the latest V1 directly from Valenting Research. I should get it tomorrow. If it isn't "tits", it is going back to the place they built it, and I am getting an 8500. After fighting zombies on the internet for years about how the V1 isn't the end all of radar detectors, I just can't believe that I picked one up.

  8. #8
    Good Citizen
    Join Date
    May 2005
    Location
    El Paso
    Posts
    177

    Default Re: V1 Price and Firefox

    Quote Originally Posted by NooB1FieD
    Hello everyone,

    I have two questions, one being does anyone know of where you can get a v1 under 400 dollars (and when maybe the next upgrade would be), and my second does anyone know why firefox doesnt work with the boards here? (I can browse, but cant post or any of the little buttons/pictures/smilies I also have BBcode plugin installed for it too.)

    Thanks for any help guys
    For your second question, Firefox works perfect. It is the only browser I use. When they released the first flavor of Mozilla (right after its Netscape days) I had to keep IE around for a few sites, but since they scrapped the old Netscape code and went with a fresh re-write I haven't had any problems with the sites I visit. I use it on both my PC and my Mac. They are also working on a little browser for the Mobile platform. I think it's called Minimo.

  9. #9
    Radar Fanatic
    Join Date
    Nov 2004
    Location
    Kentucky, USA
    Posts
    2,303

    Default

    Try re-setting to defaults on all of the security settings for firefox, i've been using it since this board started. Only problem I ever had was that it occasionally wouldn't log in on the first try using the "Log In" button up at the top, I had to use the "Log in to check private messages" thing. Other than that, it works flawlessly for me.

  10. #10
    Old Timer
    Join Date
    Jan 2005
    Location
    Ohio
    Posts
    5,182

    Default Re: V1 Price and Firefox

    Quote Originally Posted by NooB1FieD
    Hello everyone,

    I have two questions, one being does anyone know of where you can get a v1 under 400 dollars (and when maybe the next upgrade would be), and my second does anyone know why firefox doesnt work with the boards here? (I can browse, but cant post or any of the little buttons/pictures/smilies I also have BBcode plugin installed for it too.)

    Thanks for any help guys
    I believe you can call VR up and ask them for a refurbished v1 for under 400.


    As for firefox, that is all I use and I have to say ive never had problems...

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •