Results 1 to 6 of 6
  1. #1
    Good Citizen
    Join Date
    Mar 2005
    Posts
    169

    Default First Impressions: 8500 vs 8500 X50

    Alright, I bought an X50 last month and have been getting accustomed to it, and found it to to the job well. My dad decides maybe he should get a radar detector, and picks up an Original 8500 off of ebay for like $180 shipped (Detector, SmartCord, and Windshield Mount only, no box/instructions).

    I put both in my window and ran back and forth each of the known radar sources (falses).

    Both detectors reset to factory defaults (X50: Rev 5, 8500: Rev 15), then changed to Expert Meter (all other settings left factory). Mode for both is Highway (for maximum detection, even in the city, this is a test of range not falses yet).

    He was concerned maybe he'd have bought a lemon and wanted me to test his to make sure he could leave positive feedback. X50 mounted on left 6" from dead center of windshield, original 8500 mounted on right 6" from dead center of windshield (1' of seperation). Both detectors cycled multiple times and no errors come up (a good sign, but lets test range already).

    Okay, I drive by my local Shop-Rite, and they have two X-band door openers that peak at about 4/9 in highway mode, and as I round the corner both detectors nail it at seemingly the same time. As i pass by (store on left) they both track each signal properly, and as I pass by they seem to drop off X at the same time. I turn around to make sure the results are repeatable and that there arent any differences with either being closer/further away. As I pass the church and get my own first glimse of the building both detectors go off once again at what seems like the same time, and as I pass and go around the corner hang onto the X band for the same amount of time.

    Verdict: X band? Seems Identical.

    Next I test my K at a known K false at my local shopping mall. As I round the corner into the shopping center I get a weak K on my X50 and the 8500 stays silent. Then both are silent for a moment. Seconds later as I begin to pass, unfortunately both detectors reset when I hit a pothole that jolted my 3-way lighter adaptor loose (its a heavy *****, it is now in the garbage). When both snapped back to life after POST, both picked up the K immediately, and as I passed the building the X50 hung onto the signal longer with it in my rear.

    I go into the mall, and purchase this Y adaptor which has alot more give (wires instead of a solid brick thing that looks like this which is GARBAGE.)

    Okay, I come back out of the mall and there is maybe 1/4 mile of parking lot between where I parked (near radioshack) and the false (borders?). As I approach the building @ 15mph from a distance, the X50 nails the signal many seconds before the 8500. The 8500 doesnt get the K band until much closer, and as I pass the building they both seem to peak at about the same place, and as I drive away from the building (to my right side), once again the X50 stays locked onto the K signal for a longer period of time.

    Verdict: K band? X50.


    Unfortunately I cannot test KA or Laser because I have neither seen them on the highway yet, nor found a reliable stationary false signal to test them with. When I do, I will test them head-to-head.

    Keep in mind this is fairly non-scientific beacause I did not have "feet" or "mile" measurements, just eyeballing this over the period of about an hour of work. I made two passes each test, once with the source on my left, once with it on my right, perhaps multiple passes each way would have better confirmed my results. If anyone can directly compare the 8500 and X50 in laser or KA, feel free to add to this.

    Thanks for reading!

    PS: Whats the latest firmware rev. for the original 8500? Or the latest known firmware?

  2. #2
    Experienced
    Join Date
    Feb 2005
    Location
    Kansas City, MO
    Posts
    254

    Default

    i don't know what it is but since the 8500 can detect both versions of pop i wouldn't bother getting the new version since it is fairly expensive

  3. #3
    Radar Fanatic
    Join Date
    Jan 2005
    Location
    East Bay Ca
    Posts
    1,799

    Default

    Just got back from Reno/Tahoe Nev bought an X50 rev 5 before I left as my V1 was in the shop. One or two false POP in Nev no real POP encounters.

    Pro's were: few false POP alerts about five total in about 600 miles.
    Lot's of different settings. spec display, band count meter, voltage meter, automute, mute button on lighter plug included, power up information, did not appear to false Ka thought each encounter was a patrol car going the other way.

    Con's were: POP indication is OK but there should not be a full POP alert, It should be gradient audio like V1 as POP is almost always a false. Automute should be reversible during an encounter if you choose to do so, LED on lighter plug was so bright at night I had to cover it, alert tones video gamish expected the old Escort/Passport tones like V1, appeared late to pick up radar on some other people pulled over. (I was never shot)

    My 11+ year old V1 was shipped to repair less than two weeks ago, arrived home Thursday second day air no charge for anything. Noticed both antenna covers and top magnesium case cover are new. Wow

  4. #4
    Radar Fanatic
    Join Date
    Mar 2005
    Location
    Cleveland, OH
    Posts
    1,561

    Default Re: First Impressions: 8500 vs 8500 X50

    Hard to say if one detector has better filtering over the other or better range.

    If this were a V1 vs x50 test, people would say the x50 has better filtering... but in this case the conclusion is better detection range. Interesting. Presumably, both the 8500 and the x50 should use similar anti-falsing technology. But then again, door openers in reality are not falses.... just unwanted radar.

  5. #5
    Good Citizen
    Join Date
    Mar 2005
    Posts
    169

    Default

    In this case, note that H (Highway) was the setting used for both detectors, so no filtering takes place. If there is a source of radar (x/k/ka), it alerts to it.

    When I switch to A mode, this regular source of falsing doesnt register when I pass it. In fact, A is pretty quiet.

  6. #6
    Power User
    Join Date
    Nov 2004
    Location
    Maryland
    Posts
    3,939

    Default

    My X50 is REV 5. My Original 8500 is REV 15.

 

 

Similar Threads

  1. Replies: 7
    Last Post: 07-29-2010, 11:54 AM
  2. First Impressions of My 8500 X50
    By Tydog07 in forum Escort
    Replies: 7
    Last Post: 06-22-2010, 11:35 AM
  3. Weird observation between 8500 & 8500 x50
    By 01blkgts in forum Radar Detectors - General
    Replies: 10
    Last Post: 07-08-2005, 10:57 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •