Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: X Band & X50

  1. #1

    Default X Band & X50

    Hello everyone,

    I've heard and read many people on here saying that the X band for the X50 sucks compared to that of the RX65. I'm wondering how can that be since they are pretty much the same unit? And for those that have the X50, could you share your experiences with X band and how well it detected it and whether or not it was accurate or not.

    Thanks,

  2. #2
    Lead Foot
    Join Date
    Apr 2005
    Location
    Riverview, FL
    Posts
    439

    Default Re: X Band & X50

    Quote Originally Posted by tech_geek
    Hello everyone,

    I've heard and read many people on here saying that the X band for the X50 sucks compared to that of the RX65. I'm wondering how can that be since they are pretty much the same unit? And for those that have the X50, could you share your experiences with X band and how well it detected it and whether or not it was accurate or not.

    Thanks,
    To tell you the truth i've turned off X-Band on mine. I run City w/ NO X and then if I take a long trip i'll just turn it on highway. For the 5 months I've owned it i've never had an encounter with X-Band. If I were to have an encounter though, i'm 100% sure that it would give me plenty of time to slow down.

    ~Lee

  3. #3

    Default RE:

    Thanks for the reply leapoffaith!!!

  4. #4
    Old Timer
    Join Date
    Jan 2005
    Location
    Ohio
    Posts
    5,182

    Default

    I am lucky enought o have a city right next to me that uses X band. I get about a 10 second warning on X band in automode, and about a 15 second warning on highway mode at 60 MPH


    I really dont understand why people dog the x50's xband range either. In roys tests it appears to be great with a 10 mile range.

  5. #5
    Speed Demon
    Join Date
    Mar 2005
    Location
    Baltimore, MD
    Posts
    771

    Default Re: X Band & X50

    Quote Originally Posted by leepoffaith
    To tell you the truth i've turned off X-Band on mine. I run City w/ NO X and then if I take a long trip i'll just turn it on highway. For the 5 months I've owned it i've never had an encounter with X-Band. If I were to have an encounter though, i'm 100% sure that it would give me plenty of time to slow down.
    1. X-band is off
    2. Never have an encounter (if it's off, of course you won't know if you have an encounter )

    I'm following you so far, but then you lost me:
    3. i'm 100% sure it would give me plenty of time to slow down (not if it's off!)

    :shock:

    i think i know what you're saying though! :wink:

    if it were me, I'd leave it on. Buddy of mine got hit with x-band and got a mile or so warning (here in Baltimore, which reportedly didn't use x-band) on the highway. you're right, that's plenty of warning.

  6. #6
    Speed Demon
    Join Date
    Mar 2005
    Location
    Baltimore, MD
    Posts
    771

    Default

    Quote Originally Posted by Sethy
    I am lucky enought o have a city right next to me that uses X band. I get about a 10 second warning on X band in automode, and about a 15 second warning on highway mode at 60 MPH
    that's why I refuse to use auto mode.... maybe in the city but definitely not highway. the risk of reduced alert is not worth it.

    is that 15 seconds an average or a long? friend of mine was saying he got a mile warning but knowing him it was a quarter mile

    I really dont understand why people dog the x50's xband range either. In roys tests it appears to be great with a 10 mile range.
    thanks for the input, sethy. always good to have a voice of reason. nice to have someone like yourself who has both a V1 and X50 to give the straight scoop.


  7. #7
    Old Timer
    Join Date
    Jan 2005
    Location
    Ohio
    Posts
    5,182

    Default

    THaTS whAt MaKeS mE SpeCIaL!! :roll: :roll:


    haha, that 15 seconds is an averge. My long with the x50 has been about a minute.

  8. #8
    Speed Demon
    Join Date
    Mar 2005
    Location
    Baltimore, MD
    Posts
    771

    Default


  9. #9
    Lead Foot
    Join Date
    Apr 2005
    Location
    Riverview, FL
    Posts
    439

    Default Re: X Band & X50

    Quote Originally Posted by robert
    Quote Originally Posted by leepoffaith
    To tell you the truth i've turned off X-Band on mine. I run City w/ NO X and then if I take a long trip i'll just turn it on highway. For the 5 months I've owned it i've never had an encounter with X-Band. If I were to have an encounter though, i'm 100% sure that it would give me plenty of time to slow down.
    1. X-band is off
    2. Never have an encounter (if it's off, of course you won't know if you have an encounter )

    I'm following you so far, but then you lost me:
    3. i'm 100% sure it would give me plenty of time to slow down (not if it's off!)

    :shock:



    I think i know what you're saying though! :wink:

    if it were me, I'd leave it on. Buddy of mine got hit with x-band and got a mile or so warning (here in Baltimore, which reportedly didn't use x-band) on the highway. you're right, that's plenty of warning.

    If this had a face with the tounge sticking out you would get it right now :-p

  10. #10
    Speed Demon
    Join Date
    Mar 2005
    Location
    Baltimore, MD
    Posts
    771

    Default

    :P

 

 

Similar Threads

  1. Replies: 1
    Last Post: 08-17-2007, 07:16 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •