Page 1 of 3 123 LastLast
Results 1 to 10 of 25
  1. #1
    Newcomer
    Join Date
    Jul 2005
    Location
    NJ
    Posts
    40

    Default HELP! I Need Expert Advice! Weird Situation With An 8500 X50

    All right... here's my situation. Anyone knowledgable, please tell me what you think. I need to know if I actually have an Escort Passport 8500 X50 and not an imposter.

    A really good friend on myh father's purchased an RMR Product. At the time, I had no idea of the scandal with RMR. Here's the weird thing - he was sent an Escort Passport 8500 X50 free of charge. He had no idea what to do with it, and no one wanted the Escort. So, he asked my father who turned to me and asked if I wanted an Escort Passpoirt 8500 X50 for $125!!! Well I, just having purchased a new '05 Mustang GT, jumped at the chance to purchase a $400 detector for a little over $100 bucks!!!

    My dad's friend brought it over, and it was in the right box. It came with a beautiful black case and the instruction manual. Everything down to the suction cups was brand spanking new. I read the instruction booklet and went over everything so I knew how to operate it. Even ripped out the quick reference card they have in the front of the manual. I mounted the Escort in the center of my windshield, about 6 - 7 inches above my dashboard.

    When I power it up, the detector goes through this cycle: it says Passport, then 8500 X50, then it goes through all the bands (K, Ka, X, Laser) and then it shows an X band reading at full alert and then down to nothing. Then if my POP detection is on it says POP ON. Then it goes to whatever mode it is currently in. Is this the regular power up? From the videos I've watched, the tones of the detector are right.

    Now here's the weird thing - I really haven't run into many speed traps yet, so I'm not 100% sure of this thing's detection range. There is a constant K-Band speed sign by my g/f's house, but it's at the top of a hill around a turn, so the Escort won't pick it up until I'm near the top of the hill and about .2 miles away from it. Should it be picking it up further away, like a faint signal at the bottom of the hill? Also, as SOON as I pass it... like maybe 300 feet, it's gone. Seems like there's almost no rear detection, although I don't know for sure. I have no other place I know for sure there's constant radar operating. I have passed by some cops on highways/roads... even had a few overtake me from the rear... never a peep from my detector. Of course, the cops could have just been not running radar. I know this thing doesn't detect cops, only radar/laser, but I've driven over 500 highway miles and never encountered a speed trap... seems a little weird to me. Maybe the Escort isn't picking it up? It picks up very faint signals like motion detectors at shopping centers and places of business, though. This of course only further confuses me.

    I guess what's really weirding me out is that I never have those mile long detections everyone is always talking about. It's always a faint signal, then quickly up to a mid-high signal, then back down to nothing again. All in the space of about .2 - .3 miles. I almost want to hire a cop to see if this thing works, lol.

    Anyway, are there any cases of fake Escorts flying around? Like some built by RMR or something? Because this thing, if it's fake, is PERFECT. Looks exactly like the real thing, came in the right case, etc. It just seems like I've been driving WAY too long not to have encountered a speed trap in NJ. Should I take it to an Escort dealer and see if this thing needs fixing? If so, anyone have any reccomendation for NJ?

    Also, how do you check what Rev. (3 or 5) this thing is? I tried holding down all three buttons (City, Dim, Mute) but that did nothing.

    Sorry for all the questions... I'm new here.

  2. #2

  3. #3
    Advanced Member
    Join Date
    Feb 2005
    Location
    Southern MA
    Posts
    10,127

    Default Re: HELP! I Need Expert Advice! Weird Situation With An 8500

    Quote Originally Posted by EaterofWorlds
    Now here's the weird thing - I really haven't run into many speed traps yet, so I'm not 100% sure of this thing's detection range. There is a constant K-Band speed sign by my g/f's house, but it's at the top of a hill around a turn, so the Escort won't pick it up until I'm near the top of the hill and about .2 miles away from it. Should it be picking it up closer, like a faint signal at the bottom of the hill? Also, as SOON as I pass it... like maybe 300 feet, it's gone. Seems like there's almost no rear detection, although I don't know for sure.
    Their is a speed sign in my area where i only get about that amount of range and it dies quickly as well
    Here are some video's i made
    Speed signs
    Pass 1
    Pass 2
    Gernally the speed of my car in those videos range between 35-40mph and i usually get a range of 0.2mile on those signs

    Spoiler: show

    Radar Detectors-V1 & BEL v995
    Laser Jammer-Laser Interceptor Quad
    GPS Camera Locator-Cheetah C100
    GPS Nav-Garmin nuvi w/Trapster
    CB Radio-Galaxy DX-949 w/Wilson 500
    Scanner-RS Pro-96

  4. #4
    Experienced
    Join Date
    Jun 2005
    Location
    Oz
    Posts
    263

    Default

    Sounds legit to me.

  5. #5
    Speed Demon
    Join Date
    Apr 2005
    Location
    Radar Land
    Posts
    670

    Default Re: HELP! I Need Expert Advice! Weird Situation With An 8500

    Well you might have a rev 3 detector but you might be ok after all.

    When you power up the detector hit all three bottons at the same time and it will reset the detector and it will say rev 3 or rev 5

  6. #6
    Professional
    Join Date
    Jun 2005
    Location
    Dallas/Lubbock, Texas
    Posts
    917

    Default

    Sounds ok to me too...only when he checks rev number will we be sure.

  7. #7
    Radar Fanatic
    Join Date
    Mar 2005
    Location
    Staffordshire, Uk
    Posts
    1,999

    Default

    the only way to see if it is an escort is too see what the detector is like inside!

    you never know if rmr is upto something! they could make it do that!

    you could always send it to escort for service if its not right!

    they will tell you if it is an escort inside and not rmr! does sound strange why they would send him a escort for free!

    it could be an escort test one which they have tested out to see what escort uses and see what they can use! they cant copy but they can see their design and then alter theirs so they dont conflict with patent laws!

    that is strange....... i hope all turns out good!

    escort cant have rmr even if they have put a rmr inside as they havent sold it! they gave it away!

  8. #8
    Professional
    Join Date
    Jun 2005
    Location
    Dallas/Lubbock, Texas
    Posts
    917

    Default

    Man...u gotta take it easy on those exclamation marks!

    Your making me dizzy!

    Happy trails!

  9. #9
    Speed Demon
    Join Date
    Apr 2005
    Location
    Radar Land
    Posts
    670

    Default

    Quote Originally Posted by TexasRed
    Man...u gotta take it easy on those exclamation marks!

    Your making me dizzy!

    Happy trails!
    What I want to know is if and when there will be a detector that will be better then the big 3?.

    It should be lots of fun to see if this happens.

    I think it not only can happen but it will happen its just a matter of when.

  10. #10
    Professional
    Join Date
    Jun 2005
    Location
    Dallas/Lubbock, Texas
    Posts
    917

    Default

    Why did u quote me radarboy? That was irrelevant haha

 

 

Similar Threads

  1. Advice on RD in my specific situation
    By dimalm in forum Radar Detectors - General
    Replies: 8
    Last Post: 05-21-2008, 07:01 AM
  2. Need Expert Advice on Best Possible mouting Location
    By richardboy316 in forum Laser Jammers - General
    Replies: 4
    Last Post: 11-13-2006, 01:31 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •