Results 1 to 6 of 6
  1. #1
    Founder of Stealthvation
    Join Date
    Dec 2004
    Location
    Cleveland, Ohio
    Posts
    11,174

    Default X50 Self Cal Yesterday

    :cry: I seen my first self Cal on my X50 yesterday. Does this mean it is going bye bye? I had to turn it off and turn it back on when I seen this Self Cal message. MANY have told me that this is the beggining of a detector going bad. :cry:
    RIP Duncan my BELOVED black lab son 8/7/99-3/23/11. I will miss you DEARLY.


    http://www.criminalcustomzshop.com/


    LET THE BIRTH OF MANY TESTING GROUPS HAPPEN!











    You want to know what it is like doing something for the love and passion and not for the mighty dollar then look up GOL!










    buyradardetectors rocks!

  2. #2
    Power User
    Join Date
    Feb 2005
    Location
    In Car RamRod
    Posts
    4,001

    Default

    yes m8, mine flashed it up a couple times and then nothing for a month and now it goes into self cal4 and service required as soon as i turn it on...send it back..its gooonnneeeeeee.....

  3. #3
    Power User
    Join Date
    Nov 2004
    Location
    Maryland
    Posts
    3,939

    Default

    When my past 2 defective X50's did that Escort told me to send it in.

  4. #4
    Founder of Stealthvation
    Join Date
    Dec 2004
    Location
    Cleveland, Ohio
    Posts
    11,174

    Default

    I am in good hands with RadarRoy!
    RIP Duncan my BELOVED black lab son 8/7/99-3/23/11. I will miss you DEARLY.


    http://www.criminalcustomzshop.com/


    LET THE BIRTH OF MANY TESTING GROUPS HAPPEN!











    You want to know what it is like doing something for the love and passion and not for the mighty dollar then look up GOL!










    buyradardetectors rocks!

  5. #5
    Newcomer
    Join Date
    Jun 2005
    Location
    TN
    Posts
    45

    Default

    I ordered a v1, two hours later I went for a drive my 3 month old x50 went into self cal for the first time hmmmmm. My last bel (970lr) did same thing about the same age, sent it back it lasted 5 years before it started again.

  6. #6
    Old Timer
    Join Date
    Jun 2005
    Location
    New Hampshire
    Posts
    6,806

    Default

    I wonder if it's something in the air, now my 3 week old X50 threw a Self Cal a little while ago. I turned it off and back on and it seems to be working, I think, of course I won't know until I encounter some radar.

    But then with the kind of luck I've been having lately I'm not surprised one bit. I just hope it doesn't die completely before I get my V1 back.

    EDIT: Went grocery shopping, X50 threw Self Cal when leaving the store. This time I let it run through without shutting it off. After a minute or so, it rebooted and is working for now. Hopefully by letting it complete it'll be "calibrated" now. If it happens again I'll contact Roy.
    If I'm passing you on the right, YOU are in the wrong lane!

    If speed kills, how come I'm still alive?

    Active Countermeasures: V1 3.858, Escort Redline, Beltronics STi-R+, LI Dual 7.1x CPU/8.7 Heads (front)
    Other/Backup Countermeasures: V1 3.813 (loaned to friend), Beltronics Pro RX65 M4 6.3
    Vehicle: 2002 Audi A4 1.8T Quattro
    LEO Toys: Kustom Pro Laser II & III
    Encounters/Saves August 2011: Radar 3/1, Laser 0/0


 

 

Similar Threads

  1. Got my V1 yesterday
    By EMJR in forum Valentine One
    Replies: 20
    Last Post: 04-23-2011, 07:48 AM
  2. Got my V1 yesterday!
    By carpoor in forum Valentine One
    Replies: 4
    Last Post: 12-23-2006, 10:08 PM
  3. new 3.856 yesterday
    By ndlive in forum Valentine One
    Replies: 14
    Last Post: 10-08-2006, 05:58 PM
  4. Ka in NJ yesterday
    By TeamQuack in forum Local & Regional Info
    Replies: 11
    Last Post: 08-31-2006, 05:05 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •