Results 1 to 8 of 8
  1. #1

    Default How often is x50 supposed to display SELF CAL

    I got my x50 about 2 months ago, and after the first month i had to send it to escort because i got a service required. They replaced the antenna and recalibrated it. Now, ever since i got it back about 2 weeks ago, its been getting a self cal msg pretty much everytime i turn the car on. Its totally random though. I leave it on and it eventually just restarts and it seems fine. Is there something still wrong with my detector always displaying self cal?

  2. #2
    Professional
    Join Date
    Sep 2005
    Location
    indoors
    Posts
    1,099

    Default

    To answer the topic question, it's not. The Self-Cal message means that your X50 has detected a problem and is recalibrating itself to try and fix it. It's a bad thing to see, but you only need to seriously worry if it says "Service Required." Here are some ways to avoid seeing the Self-Cal message and extend the life of your detector.

    1. Unplug the detector before turning the car off, and don't plug it in until after the car is turned on. If it's hardwired, then just turn the X50 off before the car is off and turn it on after the car is on.

    2. Don't just leave it in the windshield all the time. The temperature in your car can be 40 degrees hotter than it is outside on a sunny day, and the windshield can act as a low-powered maginfying glass if it's parked towards the sun. If you have a garage, it should be ok to leave it in the car itself, but if you park your car outside, I'd seriously consider bringing the detector in with you (if it's not hardwired).

  3. #3
    Old Timer
    Join Date
    Jun 2005
    Location
    New Hampshire
    Posts
    6,806

    Default

    If you see Self Cal more than once, send it back. Ideally you should never see it.
    If I'm passing you on the right, YOU are in the wrong lane!

    If speed kills, how come I'm still alive?

    Active Countermeasures: V1 3.858, Escort Redline, Beltronics STi-R+, LI Dual 7.1x CPU/8.7 Heads (front)
    Other/Backup Countermeasures: V1 3.813 (loaned to friend), Beltronics Pro RX65 M4 6.3
    Vehicle: 2002 Audi A4 1.8T Quattro
    LEO Toys: Kustom Pro Laser II & III
    Encounters/Saves August 2011: Radar 3/1, Laser 0/0


  4. #4
    Good Citizen
    Join Date
    Jul 2005
    Location
    Colorado
    Posts
    125

    Default

    Self Cal is a bad sign most of the time. If possible you might want to try it in another vehicle to eliminate the possibility of power spikes, etc. If it continues to fail send it back !

    Also consider that other strong RF equipment in or around the vehicle might trigger it. this includes toll both transponers.

  5. #5
    Good Citizen
    Join Date
    Jul 2005
    Location
    Colorado
    Posts
    125

    Default

    A little more on-topic. I have owned the X50 for 6 months now and have never seen a single Self-Cal or service required message.

  6. #6
    Good Citizen
    Join Date
    Oct 2005
    Location
    Iowa
    Posts
    142

    Default

    After about 1 1/2 years my 8500 (non X50) started doing the Self Cal thing almost every time I used it. My X50 hasn't done this yet but it's only a little over a year old. I hope it doesn't start that too.

    BTW, the first time I saw the "Self Cal" message I told my wife "well, it looks like my radar detector decided to go to California where it's warmer!" 8)

    Seriously, I agree with everyone who says this is a bad sign. I would suggest that anyone who has this happen more than once should send it in, especially if still under warranty.

  7. #7
    Power User
    Join Date
    Nov 2004
    Location
    Maryland
    Posts
    3,939

    Default

    When I talked to Escort, they told me that I should send the detector in for repair if I see SELF CAL message even once.

  8. #8
    Professional
    Join Date
    Jun 2005
    Location
    Dallas/Lubbock, Texas
    Posts
    917

    Default

    *knocks on wood* I've had mine for over a year and I've never seen it.

 

 

Similar Threads

  1. Am I supposed to get these K alerts?
    By beepbeepboop in forum Valentine One
    Replies: 10
    Last Post: 03-19-2011, 08:24 AM
  2. I know I'm not supposed to, but I am anyway
    By stealthJamal in forum Beltronics
    Replies: 7
    Last Post: 01-09-2008, 10:04 AM
  3. How to tune the V1? What modes are supposed to be ON?
    By djdownfawl in forum Valentine One
    Replies: 13
    Last Post: 12-20-2007, 12:09 PM
  4. How to tune the V1? What modes are supposed to be ON?
    By djdownfawl in forum Valentine One
    Replies: 1
    Last Post: 12-18-2007, 11:59 PM
  5. So what's the new Blinder supposed to do?
    By statusquo in forum Blinder Laser Jammers
    Replies: 15
    Last Post: 05-31-2007, 04:40 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •