Results 1 to 9 of 9
  1. #1
    Radar Fanatic
    Join Date
    Jul 2005
    Location
    ATLANTA. Im never leaving.
    Posts
    2,418

    Default Stupid Laser falses

    I know that its got something to do with my car. cuz every detector ive had did it- my old cobras, the reg 8500 i used to have (sold it on ebay cuz i got a smoking good deal on an X50 blue on ebay, $200 practically brand new, i know its not smart to buy detectors off ebay but this was just too good to pass up ) anyway it doesnt matter where its mounted it just randomly goes off LASER. and its f-ing annoying cuz ill be on the highway or in the city and then slam on the brakes for a false. im pretty sure it has something to do with my head unit, i guess this because in my moms Lexus RX300 no matter what detector you point at the factory head unit, it goes off Laser. Also my remote for my head unit will set it off occasionally but not all the time. Does anyone else experience this kind of stuff?

  2. #2
    Old Timer
    Join Date
    Jan 2005
    Location
    Ohio
    Posts
    5,182

    Default

    Your detector that you got that good deal on, is broken.

    It will probibally display self cal soon.

  3. #3
    Radar Fanatic
    Join Date
    Jul 2005
    Location
    ATLANTA. Im never leaving.
    Posts
    2,418

    Default

    ALL my detectors do it. not just the x50. my old xrs9300, esd9200, old old esd6060, the other 8500 and this. they dont do it in other cars, trust me ive used it in 5 other cars and none do it.

    Correction not all the detectors did it, the RMR eclipse that Boomerman now has didnt do Sh*! .

  4. #4
    Old Timer
    Join Date
    Jun 2005
    Location
    New Hampshire
    Posts
    6,806

    Default

    If they only do it in that one car, then it's something in that car that's causing them. Perhaps the display you mentioned, or something in the electrical system is causing the laser falses.

    Try turning off or covering up displays on various devices in your car and see if the falses stop.
    If I'm passing you on the right, YOU are in the wrong lane!

    If speed kills, how come I'm still alive?

    Active Countermeasures: V1 3.858, Escort Redline, Beltronics STi-R+, LI Dual 7.1x CPU/8.7 Heads (front)
    Other/Backup Countermeasures: V1 3.813 (loaned to friend), Beltronics Pro RX65 M4 6.3
    Vehicle: 2002 Audi A4 1.8T Quattro
    LEO Toys: Kustom Pro Laser II & III
    Encounters/Saves August 2011: Radar 3/1, Laser 0/0


  5. #5
    Radar Fanatic
    Join Date
    Nov 2004
    Location
    Kentucky, USA
    Posts
    2,303

    Default

    You need to install a filter capacitor across the back of the lighter socket. Use a 470mfd 25volt mylar capacitor (can get them at RadioShack) and solder one lead to the ground for the lighter, and the other to the 12v. 90% certain that will take care of it.

    EDIT, should have been 470mfd, not 100 as originally stated. Sorry

  6. #6
    Speed Demon
    Join Date
    Jun 2005
    Posts
    585

    Default

    Mine was falsing a lot in a 05 Safari, when i was half throttle or flooring it, the Laser alert wouldnt stop going off, its an electrical problem for sure.

  7. #7
    Radar Fanatic
    Join Date
    Jul 2005
    Location
    ATLANTA. Im never leaving.
    Posts
    2,418

    Default

    Quote Originally Posted by compu44
    You need to install a filter capacitor across the back of the lighter socket. Use a 100mfd 25volt mylar capacitor (can get them at RadioShack) and solder one lead to the ground for the lighter, and the other to the 12v. 90% certain that will take care of it.
    Ill try that, Thanks.

  8. #8
    Radar Fanatic
    Join Date
    Jul 2005
    Location
    WNY (sometimes)
    Posts
    1,566

    Default

    Check the vehicle's voltage. If you have a weak battery or faulty alternator, you can have your voltage drop low enough to mess up your detector.

    ...happened to me in my BMW with a V1

  9. #9
    Radar Fanatic
    Join Date
    Nov 2004
    Location
    Kentucky, USA
    Posts
    2,303

    Default

    Quote Originally Posted by A-TownNavi
    Quote Originally Posted by compu44
    You need to install a filter capacitor across the back of the lighter socket. Use a 100mfd 25volt mylar capacitor (can get them at RadioShack) and solder one lead to the ground for the lighter, and the other to the 12v. 90% certain that will take care of it.
    Ill try that, Thanks.
    Let me know how it works out for you. I'm nearly certain that will take care of it.

 

 

Similar Threads

  1. Laser Falses
    By malibuboats91 in forum Valentine One
    Replies: 6
    Last Post: 10-15-2010, 02:21 PM
  2. Replies: 15
    Last Post: 09-25-2010, 02:20 PM
  3. Laser Falses
    By EVOLV3D in forum Valentine One
    Replies: 12
    Last Post: 06-19-2009, 04:28 PM
  4. Replies: 10
    Last Post: 10-23-2008, 10:54 AM
  5. Laser falses?
    By frog in forum Radar Detectors - General
    Replies: 1
    Last Post: 01-07-2005, 09:27 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •