Page 1 of 2 12 LastLast
Results 1 to 10 of 18
  1. #1
    Newcomer
    Join Date
    Jan 2006
    Location
    Houston
    Posts
    2

    Default POP issue with new Escort 8500 X50

    I received a new Escort 8500 X50 for Christmas, and while I'm quite satisfied with it so far (I used an Escort Solo since 1995), but there is something I'm a bit concerned about.

    One of the selling points for the X50 was it's capability for detecting POP radars (obviously, my old Escort did not have that). I enabled POP as soon as I got it, and ever since I've gotten POP alerts with well-nigh nauseating regularity.

    As I understand it, POP readings can't be used to give you a ticket since it's duration is too short to be accurate, and that the lawman must immediately switch over to K or Ka (I assume the latter most likely) and lock on in order to get an accurate speed indication.

    Thing is, not once have I gotten any other radar alert along with the POP. One would think that if Johnny Law had just painted me with his POP gun (and yes, if he had, in most cases I would be going over the speed limit to one degree or another), he would switch over to KA, laser or SOMETHING so as to nail me proper.

    Is there an issue with the X50 in terms of POP false alarms, or other kinds of emissions setting it off?

    Thanks...

  2. #2
    Advanced Member
    Join Date
    Feb 2005
    Location
    Southern MA
    Posts
    10,127

    Default

    What Revision do you have? Rev. 5?

    The BEL and Escort both false POP alerts. Usually set off by Cobra radar detectors

    Spoiler: show

    Radar Detectors-V1 & BEL v995
    Laser Jammer-Laser Interceptor Quad
    GPS Camera Locator-Cheetah C100
    GPS Nav-Garmin nuvi w/Trapster
    CB Radio-Galaxy DX-949 w/Wilson 500
    Scanner-RS Pro-96

  3. #3
    Professional
    Join Date
    May 2005
    Location
    New England
    Posts
    1,071

    Default

    Turn the POP off. It's intolerable.

  4. #4
    ES13Raven
    Guest

    Default Re: POP issue with new Escort 8500 X50

    Quote Originally Posted by Cave Bear
    Is there an issue with the X50 in terms of POP false alarms, or other kinds of emissions setting it off?
    No... Crappy craftsmanship by Cobra and other poorly designed detectors are setting your POP off. Take a look around for other drivers with radar detectors next time it goes off and I bet you can find them.

    If you need POP detection without a lot of POP falses, I recommend the RX65 :wink:

    I talk all about it here:
    http://radardetector.net/RX65-has-it...-not-6434t.php

  5. #5
    Good Citizen
    Join Date
    Jan 2006
    Posts
    105

    Default Re: POP issue with new Escort 8500 X50

    Quote Originally Posted by Cave Bear
    I received a new Escort 8500 X50 for Christmas, and while I'm quite satisfied with it so far (I used an Escort Solo since 1995), but there is something I'm a bit concerned about.

    One of the selling points for the X50 was it's capability for detecting POP radars (obviously, my old Escort did not have that). I enabled POP as soon as I got it, and ever since I've gotten POP alerts with well-nigh nauseating regularity.

    As I understand it, POP readings can't be used to give you a ticket since it's duration is too short to be accurate, and that the lawman must immediately switch over to K or Ka (I assume the latter most likely) and lock on in order to get an accurate speed indication.

    Thing is, not once have I gotten any other radar alert along with the POP. One would think that if Johnny Law had just painted me with his POP gun (and yes, if he had, in most cases I would be going over the speed limit to one degree or another), he would switch over to KA, laser or SOMETHING so as to nail me proper.

    Is there an issue with the X50 in terms of POP false alarms, or other kinds of emissions setting it off?

    Thanks...
    Well true they have to switch to k or ka after using pop to track your speed,but I doubt most will play fair and do that. If your driving and you get a pop alert with no k or ka band to follow. More than likely it could be a LEO using it down the road,behind you, from a side st. And the x50 is catching a reflect of a object. I onlly get maybe one or 2 falses on pop a week since I had mine.

  6. #6
    Experienced
    Join Date
    Dec 2005
    Location
    Southern California
    Posts
    268

    Default Re: POP issue with new Escort 8500 X50

    Quote Originally Posted by ES13Raven
    Quote Originally Posted by Cave Bear
    Is there an issue with the X50 in terms of POP false alarms, or other kinds of emissions setting it off?
    No... Crappy craftsmanship by Cobra and other poorly designed detectors are setting your POP off. Take a look around for other drivers with radar detectors next time it goes off and I bet you can find them.

    If you need POP detection without a lot of POP falses, I recommend the RX65 :wink:

    I talk all about it here:
    http://radardetector.net/RX65-has-it...-not-6434t.php
    ive been using the pop on my rx 65 and i havent falsed once yet!!!!!!


    yes i said it, once..!!!


    so i think in that case the rx 65 perfoms better than the x50 which seems to have a huge problem with pop falses (your not the first to complain)

  7. #7
    Good Citizen
    Join Date
    Feb 2005
    Posts
    197

    Default

    turned my pop off...it was literally just killing me!! (chicago area)

  8. #8
    Lead Foot
    Join Date
    Jan 2006
    Location
    Ohio
    Posts
    444

    Default POP falsing

    The X50 is likely to false more in POP mode vs the RX65. The RX65 limits its Ka sweep to actual Radar bands, 33.8, 34.7, 35.5 GHz. I believe the X50 sweeps the entire Ka range all the time. To detect POP the units have to sweep Ka Lower, that would be 33.8 over and over and over. Since POP is so short a xmission...the only way to really alert on so short a signal is to abandon some or all of the Ka falsing rejection schemes. Or alert on anything that even resembles some signal energy.
    Those of you that live in areas with POP are going to have to learn to live with some falsing. I never run POP, but it isn't known to be used where I live. I don't run it because of the false alerts. If you don't need it don't use it.

  9. #9
    Founder of Stealthvation
    Join Date
    Dec 2004
    Location
    Cleveland, Ohio
    Posts
    11,174

    Default

    Happya$$ has POP turnd off on the X50 and the V1 and so should you. Happya$$ would not have it any other way since Happya$$ says that one has a better chance of getting struct by lighting than getting nailed with POP
    RIP Duncan my BELOVED black lab son 8/7/99-3/23/11. I will miss you DEARLY.


    http://www.criminalcustomzshop.com/


    LET THE BIRTH OF MANY TESTING GROUPS HAPPEN!











    You want to know what it is like doing something for the love and passion and not for the mighty dollar then look up GOL!










    buyradardetectors rocks!

  10. #10
    ES13Raven
    Guest

    Default Re: POP falsing

    Quote Originally Posted by insidercw3
    The X50 is likely to false more in POP mode vs the RX65.
    I have both detectors, and this is true.
    The RX65 limits its Ka sweep to actual Radar bands, 33.8, 34.7, 35.5 GHz. I believe the X50 sweeps the entire Ka range all the time.
    But this is not why it is true. The RX65 actually POP falses more using the USA / AccuSweep mode which only scans known police radar bands. My RX65 never POP falses using INTL mode.

 

 

Similar Threads

  1. Replies: 16
    Last Post: 12-29-2009, 12:01 AM
  2. Replies: 17
    Last Post: 04-22-2009, 06:44 AM
  3. Escort Customer Service Issue
    By Orbital75 in forum Escort
    Replies: 3
    Last Post: 12-07-2007, 12:09 PM
  4. Replies: 10
    Last Post: 07-31-2006, 09:43 AM
  5. Difference beteen the Escort 8500 and Escort 8500 X50 ?
    By bentvalve in forum Radar Detectors - General
    Replies: 10
    Last Post: 10-14-2005, 01:20 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •