Results 1 to 2 of 2

Thread: 8500 no sound

  1. #1

    Default 8500 no sound

    recently my 8500 sound had stoped working i dunno if it is the speaker or the main board. has anyone had this problem before. And also what kind of speaker is in it and were can i get one?

  2. #2
    Experienced
    Join Date
    Feb 2005
    Location
    Kansas City, MO
    Posts
    254

    Default

    I've never had this problem before. You might try completely resetting your detector to see if that helps for some weird reason. If this doesn't work i don't know where you can get a replacement internal speaker but there is a spot on the side of the detector where you can plug headphones into. if you can't find a replacement speaker for inside it i would just get some external speakers and hook them into the head phone port. There is also a possibility you could wire up some speakers and mount them and also plug into the head phone port. hope this helps.

 

 

Similar Threads

  1. Replies: 6
    Last Post: 04-16-2008, 07:15 PM
  2. 995 sound q
    By focalcivic in forum Beltronics
    Replies: 3
    Last Post: 03-24-2008, 07:06 PM
  3. LPP sound q
    By focalcivic in forum Laser Jammers - General
    Replies: 10
    Last Post: 03-12-2008, 02:29 PM
  4. How does this sound?
    By carter840 in forum Laser Jammers - General
    Replies: 5
    Last Post: 01-07-2007, 01:49 PM
  5. What does Ku sound like?
    By TexasRed in forum Valentine One
    Replies: 7
    Last Post: 03-29-2006, 03:33 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •