Page 1 of 2 12 LastLast
Results 1 to 10 of 18
  1. #1
    Newcomer
    Join Date
    Feb 2006
    Posts
    10

    Default service required comin up alot

    Ok, i have had the x50 for about a year and 9 months. Now all of a sudden im getting this service required popping up, and when i been turning it on, you know how it usually goes through its stages, it will freeze on LASER. I lost my manual so dont know where the reset button is, heard that the reset button would fix this. I seen in a forum you hold three buttons down. I only see 2 on mine :roll: . Any help would be appreciated . Of course this starts happening after my warranty is up :x

  2. #2
    Yoda of Radar
    Join Date
    Nov 2005
    Location
    NY
    Posts
    11,016

    Default

    There are two buttons on the top... then a small colored button (mute) button just to the right of the smooth matrix display, its a groved button. Those are the 3 buttons you speak of...the 'mute' button is 'tinted to the display color and groved' so if you dont know where it is its hard to find.

    BTW: How did you own the X50 for nearly 2 years and didnt know where the (manual) mute button was? It is the only way to change bands... ie POP on/off etc etc... or just find it mentioned or shown in the manual? That is odd to me.


    I wouldnt imagine it would fix your problems for that long, it could maybe help out constant 'self-cal' messages, but service required means it needs service so send it in pretty much. Its worth a try to reset it though.

  3. #3
    Professional
    Join Date
    Nov 2004
    Posts
    1,397

    Default

    All the reset does is reset the settings, it doesn't really help with much else.

  4. #4
    Newcomer
    Join Date
    Feb 2006
    Posts
    10

    Default

    Quote Originally Posted by AirMoore
    BTW: How did you own the X50 for nearly 2 years and didnt know where the (manual) mute button was? It is the only way to change bands... ie POP on/off etc etc... or just find it mentioned or shown in the manual? That is odd to me.
    I always used the mute button on the cigarette lighter. I never really messed with the modes, only between city and highway. I should of got that 2 yr extended warranty for 29 bucks :roll:

    One question, found the mute button, do i just hold all 3 down while the car is off?

  5. #5
    Yoda of Radar
    Join Date
    Mar 2005
    Location
    Rottweiler Land
    Posts
    10,420

    Default

    You need to send that bad boy in for service....... :cry:

  6. #6
    Radar Fanatic
    Join Date
    Mar 2005
    Location
    Staffordshire, Uk
    Posts
    1,999

    Default

    manuals can be downloaded in pdf

    hope this helps..... http://www.escortradar.com/8500x50manual.pdf


  7. #7
    Good Citizen
    Join Date
    Jul 2005
    Location
    Colorado
    Posts
    125

    Default

    Quote Originally Posted by shadow_
    Quote Originally Posted by AirMoore
    BTW: How did you own the X50 for nearly 2 years and didnt know where the (manual) mute button was? It is the only way to change bands... ie POP on/off etc etc... or just find it mentioned or shown in the manual? That is odd to me.
    I always used the mute button on the cigarette lighter. I never really messed with the modes, only between city and highway. I should of got that 2 yr extended warranty for 29 bucks :roll:

    One question, found the mute button, do i just hold all 3 down while the car is off?
    First remove power from the X50, either by pulling the cigarette lighter plug, or the thumbwheel switch on the side. Next depress all three buttons, the two on the top, and the front mute button. (the Vulcan death grip) Now with all three buttons still held down, apply power to the X50.

  8. #8
    Newcomer
    Join Date
    Jan 2006
    Location
    CT
    Posts
    66

    Default

    If youre getting a Service Required, you need to send that in. By holding down all three buttons, all youre doing is reseting the unit to all its factory settings and showing the Rev #. If there is a problem like the unit falling out of tune, it needs to be fixed soon to get the performance the X50 is supposed to have.

  9. #9
    Newcomer
    Join Date
    Feb 2006
    Posts
    10

    Default

    how much do they charge to fix it though? As much as a new radar? Plus the shipping costs. Its not under warranty either

  10. #10
    Yoda of Radar
    Join Date
    Mar 2005
    Location
    Rottweiler Land
    Posts
    10,420

    Default

    Quote Originally Posted by shadow_
    how much do they charge to fix it though? As much as a new radar? Plus the shipping costs. Its not under warranty either
    Usually about $85

 

 

Similar Threads

  1. Service Required
    By declansdad in forum Beltronics
    Replies: 18
    Last Post: 09-07-2010, 11:56 AM
  2. STI Service Required
    By Sparkknocker in forum Beltronics
    Replies: 18
    Last Post: 07-10-2007, 08:34 PM
  3. service required...?
    By DiabloGT in forum Escort
    Replies: 5
    Last Post: 11-14-2006, 08:59 PM
  4. It says Service Required.
    By SIX in forum Beltronics
    Replies: 11
    Last Post: 05-10-2006, 06:05 PM
  5. Service required
    By wanderingmind12 in forum Escort
    Replies: 5
    Last Post: 08-18-2005, 05:46 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •