Results 1 to 10 of 10
  1. #1
    Good Citizen
    Join Date
    Jul 2005
    Location
    Corydon,IN
    Posts
    177

    Default Ka or K and X at same time

    Anyone know why sometimes I get a X alert and a K or Ka at the same time...especially when I get close to the policeman I finally start to get a X signal in addition to the K or Ka. Mainly I have seen this when the officer already has someone pulled over??? Thanks :?

  2. #2
    Advanced Member
    Join Date
    Dec 2004
    Location
    Michigan
    Posts
    7,509

    Default Re: Ka or K and X at same time

    Quote Originally Posted by X50 Radar Kid
    Anyone know why sometimes I get a X alert and a K or Ka at the same time...especially when I get close to the policeman I finally start to get a X signal in addition to the K or Ka. Mainly I have seen this when the officer already has someone pulled over??? Thanks :?
    Sounds to me like the detector gets "overloaded" at close range causing the additional X-band alert....

  3. #3
    Old Timer
    Join Date
    Jun 2005
    Location
    New Hampshire
    Posts
    6,806

    Default

    My V1 often sounds a 2nd, weaker Ka signal when near a cruiser running K or Ka. It's probably the same thing, RD circuits get overloaded and clip, and a resulting harmonic gets detected as another radar signal.
    If I'm passing you on the right, YOU are in the wrong lane!

    If speed kills, how come I'm still alive?

    Active Countermeasures: V1 3.858, Escort Redline, Beltronics STi-R+, LI Dual 7.1x CPU/8.7 Heads (front)
    Other/Backup Countermeasures: V1 3.813 (loaned to friend), Beltronics Pro RX65 M4 6.3
    Vehicle: 2002 Audi A4 1.8T Quattro
    LEO Toys: Kustom Pro Laser II & III
    Encounters/Saves August 2011: Radar 3/1, Laser 0/0


  4. #4
    Good Citizen
    Join Date
    Jul 2005
    Location
    Corydon,IN
    Posts
    177

    Default

    So I guess this would be the reason that I get an X signal 2 seconds before going to a full Ka if it is instant on...and like if the officer is about 500 feet from me??
    Like it is picking up the X Signal as being when they push the button and it taking a couple of seconds to send out a Ka signal??

  5. #5
    Old Timer
    Join Date
    Jun 2005
    Location
    New Hampshire
    Posts
    6,806

    Default

    So you're getting X before Ka if the officer is using instant-on? If that's the case, the X is probably caused by something else in the cruiser.
    If I'm passing you on the right, YOU are in the wrong lane!

    If speed kills, how come I'm still alive?

    Active Countermeasures: V1 3.858, Escort Redline, Beltronics STi-R+, LI Dual 7.1x CPU/8.7 Heads (front)
    Other/Backup Countermeasures: V1 3.813 (loaned to friend), Beltronics Pro RX65 M4 6.3
    Vehicle: 2002 Audi A4 1.8T Quattro
    LEO Toys: Kustom Pro Laser II & III
    Encounters/Saves August 2011: Radar 3/1, Laser 0/0


  6. #6
    Good Citizen
    Join Date
    Jul 2005
    Location
    Corydon,IN
    Posts
    177

    Default

    Quote Originally Posted by kpatz
    So you're getting X before Ka if the officer is using instant-on? If that's the case, the X is probably caused by something else in the cruiser.
    Yeah thats what I was thinking....something else in the cruiser setting the X off...but this has happended twice...where the x comes like a second or so...before....I am on expertmeter mode and if I am within 500 feet or so....

  7. #7
    Speed Demon
    Join Date
    Apr 2005
    Location
    Radar Land
    Posts
    670

    Default Re: Ka or K and X at same time

    Quote Originally Posted by X50 Radar Kid
    Anyone know why sometimes I get a X alert and a K or Ka at the same time...especially when I get close to the policeman I finally start to get a X signal in addition to the K or Ka. Mainly I have seen this when the officer already has someone pulled over??? Thanks :?
    You may have gotten a bad X50 as I have never heard of this happing to anyone. Return it if you can.

    Also try turning off X band and see if you get the same results.

  8. #8
    Good Citizen
    Join Date
    Jul 2005
    Location
    Corydon,IN
    Posts
    177

    Default

    I bought my unit from Escort Direct and it is Rev 5 so I dont think there is anything wrong ...there must just be something else its picking up but I know if you turn of X band it is not going to show an X signal :roll:

  9. #9
    Cheetah Rep
    Join Date
    Feb 2005
    Location
    Phoenix, Arizona
    Posts
    2,567

    Default

    Quote Originally Posted by X50 Radar Kid
    So I guess this would be the reason that I get an X signal 2 seconds before going to a full Ka if it is instant on...and like if the officer is about 500 feet from me??
    Like it is picking up the X Signal as being when they push the button and it taking a couple of seconds to send out a Ka signal??
    I've had that same experience before. i think i even mentioned it here some time back. when i had x band enabled on the 8500 i would get an x blip, then suddenly a strong ka alert. i figured it was some kind of pre-warning.

    I found it, from back in Feb.
    http://www.radardetector.net/viewtop...ighlight=#2533

    i say keep it, any extra warning helps.

  10. #10
    Professional
    Join Date
    Jan 2005
    Location
    Washington, D.C.
    Posts
    968

    Default

    if you are getting multiple Ka alerts, and only 1 cop car, it could be that both radars are on (front and back)

    OR

    you are picking up 2 radar reflections..


    as to why you are getting x band single during a ka alert? sounds like your detector needs to be replaced.

 

 

Similar Threads

  1. Long time reader, first time poster
    By frozendevl in forum Introduce Yourself
    Replies: 11
    Last Post: 04-27-2011, 11:44 PM
  2. Long time reader, First time poster from KY
    By Goofy Footr in forum Introduce Yourself
    Replies: 8
    Last Post: 03-30-2010, 06:51 PM
  3. Replies: 11
    Last Post: 09-22-2009, 04:35 PM
  4. Google maps time vs. actual time....
    By tosi in forum Radar Detectors - General
    Replies: 10
    Last Post: 02-17-2009, 12:26 PM
  5. 4th time apply Veil and Final Time!!
    By StlouisX50 in forum Laser Veil Stealth Coating
    Replies: 3
    Last Post: 04-13-2006, 09:02 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •