Results 1 to 5 of 5
  1. #1
    Radar Fanatic
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    2,357

    Default Some observations from my weekend

    I drove about 300 miles this weekend and I haven't seen any evidence that my V1 has any problems.

    First, I got another chance to test out the false alarm guard against a stationary (and very weak) Ka signal from a police car in a parking lot. There was absolutely no difference in warning range as far as I could tell. I made about 4 or 5 passes, toggling the guard each time. I got a few hundred feet of warning no matter what, which isn't too bad considering that the radar unit was pointed directly into a masonry building. Can't expect much there.

    I only had one legitimate encounter with radar, and that was in Rhode Island. There was a state trooper parked facing south-bound at the end of a south-bound service area on 95. I was headed north bound and caught what I think was an instant-on hit on Ka. This was another lousy situation for catching it because my elevation was probably 20 or 30 feet above his and I was coming around a bend. I wondered for a second if he was checking my speed but I don't think that would have been possible.

    Finally, the false alarm guard did a really good job at keeping down the falses. I would have expected the V1 to drive me a little nuts in all that traffic but I didn't get a single un-explained Ka false. I got only one Ka blip and the "J" indicator cancelled it almost as soon as it started. No real radar in the area.

    Next weekend has the potential for another 500-600 miles of driving across southern New England and New York, and then later in the month I should be headed for NH and Maine. If there really are any problems with this firmware version, I'm bound to find out by the end of July!

  2. #2
    Old Timer
    Join Date
    Jun 2005
    Location
    New Hampshire
    Posts
    6,806

    Default

    Cool. I anxiously await your report. If you come thru NH, I'm curious how your V1 responds to NH statey's Ka guns. Mine often reports 2 bogeys instead of 1 when near the cruiser. One time last weekend my V1 reported 3 bogeys when there were 2 cruisers. They upgraded from K to Ka guns within the past couple years, and this sort of thing never happened back when they were using K band.

    NH has laser too, but it isn't as commonplace as Ka.
    If I'm passing you on the right, YOU are in the wrong lane!

    If speed kills, how come I'm still alive?

    Active Countermeasures: V1 3.858, Escort Redline, Beltronics STi-R+, LI Dual 7.1x CPU/8.7 Heads (front)
    Other/Backup Countermeasures: V1 3.813 (loaned to friend), Beltronics Pro RX65 M4 6.3
    Vehicle: 2002 Audi A4 1.8T Quattro
    LEO Toys: Kustom Pro Laser II & III
    Encounters/Saves August 2011: Radar 3/1, Laser 0/0


  3. #3
    Radar Fanatic
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    2,357

    Default

    Thanks for the heads-up. I'll be on the lookout.

  4. #4
    Good Citizen
    Join Date
    May 2005
    Location
    Connecticut
    Posts
    127

    Default

    I have ver 3.824, but didnt see a J on my display the other day....I had a Ford Explorer behind me for about 4 miles (on Rt 8 in CT), and I had a solid, strong KA signal the whole time. I finally realized he had a detector as well, but shouldnt it have "J"'d out?

  5. #5
    Radar Fanatic
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    2,357

    Default

    Quote Originally Posted by brian1972ct
    I have ver 3.824, but didnt see a J on my display the other day....I had a Ford Explorer behind me for about 4 miles (on Rt 8 in CT), and I had a solid, strong KA signal the whole time. I finally realized he had a detector as well, but shouldnt it have "J"'d out?
    That happens to me once in a while. I thought my false alarm guard wasn't working until this weekend because that was only the third "J" I've ever seen. I don't know exactly why Ka alerts still get through but my speculation is that it always alerts to strong signals just in case. I think it's only extremely crappy detectors that do it.

 

 

Similar Threads

  1. An observations
    By suntzuaow in forum Valentine One
    Replies: 1
    Last Post: 05-30-2012, 08:56 AM
  2. STi-R Plus Observations
    By ISF GUY in forum Beltronics
    Replies: 13
    Last Post: 03-11-2011, 01:08 PM
  3. Switching from x50 to STi, my observations
    By lennyo3034 in forum Beltronics
    Replies: 2
    Last Post: 01-02-2008, 11:08 PM
  4. Recent observations of the V1.
    By crazyVOLVOrob in forum Valentine One
    Replies: 17
    Last Post: 03-26-2006, 08:48 PM
  5. STI Observations
    By ronsc1985 in forum Beltronics
    Replies: 17
    Last Post: 03-23-2006, 04:13 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •