Results 1 to 5 of 5
  1. #1

    Default V1 Display not working

    I purchased a V1 last week and hard wired it the same day. It worked great until today. When I plugged it in today, it powered up fine. It went through it's routine of tests (loud beep, softer beep, etc.), but then the display shut off. I disconnected it and tried again. Same thing. I started driving and left it in that state (a blank display) and behold, the detector is on, but the display was not working. When I passed by the super market, I got the usual multiple bogey alerts from the doors, but NO lights at all!?
    I then hooked up the detector to the cigarette lighter adaptor and it worked perfect (display came on and stayed on). I ripped the hardwire out and started again thinking it was just a poor ground. I ruled this out because I was grounding it to bare sheet metal (I scraped the paint away to make sure it was a good connection). I then checked the 12V+ with a multi-meter and is was reading 12.22V, which is just fine. I tried two different phone connectors (both the straight and curled one that came with it) and the same blank display appeared. The only thing I can think of is the direct-wire power adaptor is bad. Anyone else seen this before? Anyone else have any other ideas? Thanks for the insight!

  2. #2
    Radar Fanatic
    Join Date
    Feb 2005


    Sounds like a fault in the direct wire adapter. The V1 will normally shut off its display when you have the remote display plugged in, though the main unit will go through its self test before going dark. If the V1 thinks that it has a remote display, it would behave exactly as you describe. Call VR and describe the problem. It's a brand new unit so they will probably just send you a new direct wire adapter, maybe ask you to send the old one back so that they can figure out what went wrong.

  3. #3


    Yea, you are probably right. I would seem logic that the power adaptor thinks there is the hidden display attached. I will give them a call and see what they say. Thanks for the reply! I will keep everyone posted.

  4. #4


    I talked to a V1 rep today and he echoed the same thing as above. He stated that pins one and four (on the data cable) are data pins, and pins two and three are power pins. He said that if pin one or four are receiving any sort of power signal, the display shuts off because it thinks that the aux. display is attached. My problem makes sense now because I was getting signal on pin one when I checked all the pins with the multi-meter. He said it is most likely the defective direct-power adapter. They are sending me a new one. I'll let you guys know if that was the problem.

  5. #5


    It turns out the direct-wire power adapter was the culprit. I got a replacement from Valentine today and it works as it should now. Hope this thread helps someone out in the future...



Similar Threads

  1. Concealed Display not working any more
    By kb350z in forum Valentine One
    Replies: 5
    Last Post: 11-29-2009, 11:52 PM
  2. solo2 display not working
    By s4driver01 in forum Escort
    Replies: 7
    Last Post: 10-19-2007, 10:10 PM
  3. Replies: 30
    Last Post: 03-29-2007, 01:25 AM
  4. Concealed display not working T_T
    By oppa in forum Valentine One
    Replies: 5
    Last Post: 08-05-2006, 02:46 PM
  5. Why Isn't My Concealed Display Working?
    By hankd in forum Valentine One
    Replies: 5
    Last Post: 10-18-2005, 09:04 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts