I will be purchasing a V1 at the end of summer, and Ive heard from several people that the new version is having some issues. If I requested an older, more stable, more reliable flash version would they do that, or is everything from the factory the brand new version?