Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1

    Default Windshield Suction Cups Suck!

    I recently got a Pro 58 and the dual 1" baby suction cups SUCK! I work in the city and the damn thing came loose 4 times a day before I sucked it up and went to Home Depot to get one big suction cup to replace them. I have just tried put the big suction cup on today and I'll have to test it out for a while to see if the problem goes away.

    95N in Richmond, VA at Boulevard exit.

    I got a FULL VG-2 alert recently. Do these usually FALSE alert? :?:

    On another occasion in the same area, I got a FULL X band alert as a state trooper rolled by, FYI :wink:

  2. #2
    ES13Raven
    Guest

    Default Re: Windshield Suction Cups Suck!

    Quote Originally Posted by knukey
    I recently got a Pro 58 and the dual 1" baby suction cups SUCK!
    I haven't had any problems with mine....

  3. #3
    Professional
    Join Date
    May 2005
    Posts
    928

    Default

    I have had no problems either.
    Maybe he got a bad set or something.
    Another tip for everyone, Clean those windows before applying the suction cups.

  4. #4
    Speed Demon
    Join Date
    Jul 2005
    Location
    Indiana
    Posts
    701

    Default

    Try cleaning the suction cups and the windshield with Windex or some product with ammonia in it. You should be fine after that. My Pro 73 suctions cups are just fine.

  5. #5
    ES13Raven
    Guest

    Default

    It also helps to slightly moisten the suction cups before sticking them :wink:

  6. #6
    Radar Fanatic
    Join Date
    Nov 2004
    Location
    Kentucky, USA
    Posts
    2,303

    Default Re: Windshield Suction Cups Suck!

    Quote Originally Posted by knukey

    I got a FULL VG-2 alert recently. Do these usually FALSE alert?
    Whistler's are known to false a lot on VG2, it can be disabled if you look in the manual.

  7. #7
    ES13Raven
    Guest

    Default

    It comes disabled out of the box.... :wink:

  8. #8
    Professional
    Join Date
    May 2005
    Posts
    928

    Default

    For you to get a VG2 false alert you had to enable it.
    Turn it off!! It does affect performance!

  9. #9

    Default Suction cups

    I tried cleaning the windshield with Windex and later rubbing alcohol (had some lying around thought I would try it). I now have 3 - big suction cups mounted in a T-pattern and the thing still is not holding well. What is on the windshield preventing a good bond? I have it mounted in top left corner of my Silverado. Next step, Stickem?

  10. #10
    Professional
    Join Date
    May 2005
    Posts
    928

    Default

    Wow sounds like you have something on the windshield.
    If rubing alcohol will not clean what is on your windshield you may not be able to use suction cups.

    Does the truck ride rough? (just thinking maybe this may be the reason)
    Not out 4 weeling the truck are you?

    One thing that I know will strip anything off the glass is claybar if you know what that is.
    If you do not, claybar is used for detailing cars with.
    You might try this on the window.

 

 

Similar Threads

  1. My 'suction cups suck' mount.
    By supercowpowers in forum Valentine One
    Replies: 16
    Last Post: 11-26-2009, 11:13 AM
  2. Suction cups keep falling off from windshield
    By a529612 in forum Valentine One
    Replies: 17
    Last Post: 01-22-2009, 01:21 PM
  3. Suction cups suck (or no longer do I should say)
    By joey_corleone in forum Escort
    Replies: 25
    Last Post: 01-08-2008, 11:28 AM
  4. Grrrrrrrrrr Suction cups on the cold windshield
    By tnharley in forum Valentine One
    Replies: 26
    Last Post: 01-05-2008, 11:17 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •