Page 1 of 3 123 LastLast
Results 1 to 10 of 23
  1. #1
    Professional
    Join Date
    May 2005
    Posts
    928

    Default Great Customer Service

    I know there has been a lot of talk of bad customer service from Escort/Bel lately and I wanted to let you know about the GREAT service I received from Whistler today.

    I have an older Whistler Detector model#1773 that the speaker had blown.
    I contacted Whistler today and asked about getting a replacement speaker for this and to find out how much it would cost me to buy the speaker and replace it myself.

    Whistler said they would send me a replacement speaker at no charge!!

    That is GREAT customer service!!

  2. #2
    Good Citizen
    Join Date
    Feb 2005
    Posts
    131

    Default

    That is what my Whistler 1750 did too. DEFECT?????

    I just emailed them about my 1750. I asked them if this was a defect in their product and what can I expect out of my new Pro 73? And what can I do about the older 1750 I have? It seems to work except for the unreliable audio warnings.......lack of mostly. I have had a bad experience resulting from the lack of audio of this detector and realized too late that it was unreliable!

    Let's see what they do?

  3. #3
    Professional
    Join Date
    May 2005
    Posts
    928

    Default

    Since the 1750 and the 1773 both use the voice alert I am betting that is what is causing the blown speaker.
    At high volumes the voice alert is really distorted and you can hear the speaker crackling.

    I would bet if you disable the voice alerts when using the detector at high volume the speaker would not blow.

    Also the speaker in my pro58 is a different speaker and ohms then what is in my 1773 unit.
    This may have fixed the problem with the newer ones.

  4. #4
    Good Citizen
    Join Date
    Feb 2005
    Posts
    131

    Default

    I hope that they fixed the problem. Both are good detectors, I do like the Pro 73 better and it is a lot more sensitive than the older model.

  5. #5
    Good Citizen
    Join Date
    Feb 2005
    Posts
    131

    Default

    I can't believe the support from Whistler!!! I am impressed!!! Here is the reply from the support at Whistler:
    "I understand your concern based on your experience; however I can assure you that although the audio circuits are the same, the speaker quality has improved since the 1750 came out 3 to 4 years ago, so you shouldn’t run into any problems with your PRO 73.

    I will also be happy to send a replacement speaker to you for your model 1750 at our expense, so it will work properly again as well."

    I sent them a rely thanking them for the speaker for my old 1750. Now I may be able to take it our of the drawer and put it to some use.

  6. #6
    Professional
    Join Date
    May 2005
    Posts
    928

    Default

    Like I said, Whistler does provide great customer service!!!
    Glad to hear that others are getting the same great service I got!

  7. #7
    Speed Demon
    Join Date
    Jul 2005
    Location
    Indiana
    Posts
    701

    Default

    I have not been able to contact them in the last couple of weeks. They give alternative numbers that are not 800 numbers. I have an older Whistler 1430 and was wondering why it does not alert to X or K band at all. It still alerts to Ka but that's it. It has been over a year since it has reported a X or K band alert and these bands are alive and well in my area. I have an RX65 to prove it. I was wondering if the detector is just on its last leg or if the frequencies have changed so it is now unable to detect. Granted it is an old detector that was purchased in 1994, but I am curious. Any ideas?

  8. #8
    Manufacturer
    Join Date
    Jun 2005
    Location
    Massachusetts
    Posts
    1,263

    Default

    What # did you call. Whistler has the same customer service # for over 10 years. 1-800-531-0004
    The 1430 is well out of warranty and it would be best to upgrade.
    Check to see if there is a trade in policy.
    You may be able to save a bit of money on a new model.

  9. #9
    Speed Demon
    Join Date
    Jul 2005
    Location
    Indiana
    Posts
    701

    Default

    I realize that the 1430 is very old and out of warranty but I was just curious as to why it no longer detected X or K band. Is it defective or has frequency changed out of its range? I am dialing the same number as always 1800-531-0004 and they are giving a recording that an agent is unavailable to come to the phone. They give the option for you to call another number in which is long distance or leave a message for them to call you back. I have always been able to talk with someone but the last couple of weeks have been a no go. I recently sold a Pro 73 about 3 weeks ago and purchased a RX65. The Pro 73 was decent, but I could not stand all of the falsing especially on Ka. I never knew if the threat was real or not because it falsed so much. Any ideas on the 1430? Are frequencies outside of its range or is it just old and defective?

  10. #10
    Professional
    Join Date
    May 2005
    Posts
    928

    Default

    Sounds like to me the unit is just dying. Time to give it a proper trash can burial :wink:

 

 

Similar Threads

  1. Great customer service
    By fire65 in forum Valentine One
    Replies: 11
    Last Post: 03-11-2011, 08:02 AM
  2. Thanks Don for the great customer service!
    By crazyVOLVOrob in forum Other Countermeasures
    Replies: 0
    Last Post: 12-15-2008, 03:44 PM
  3. great customer service
    By bigmack in forum Whistler
    Replies: 6
    Last Post: 07-02-2008, 03:27 AM
  4. Great Customer Service!
    By f_399 in forum Valentine One
    Replies: 11
    Last Post: 06-26-2005, 04:25 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •