Results 1 to 2 of 2
  1. #1
    Join Date
    Sep 2010
    Philadelphia, Pennsylvania, United States

    Default Issue with Whistler 1788

    I have had the Whistler 1788 for about 18 months now. About 6 months ago, the plug that goes into the car lighter burned up and stopped working. However, I bought some rechargable batteries and have been using them without a problem since. Now, the unit has just stopped working. I tested using regular new batteries and the rechargeables and the batteries work fine. However, the unit will not turn on at all. Is there a fuse or something in there that I need to change? Anything else I can do to get this thing working?

    Thanks in advance

  2. #2
    Join Date
    Jun 2005

    Default Re: Issue with Whistler 1788

    sending you a PM



Similar Threads

  1. Whistler xtr560 vs. de 1788
    By maroonandgold45 in forum Whistler
    Replies: 2
    Last Post: 08-21-2006, 03:51 PM
  2. Whistler 1788 difference
    By boomerman in forum Whistler
    Replies: 3
    Last Post: 04-05-2006, 09:40 PM
  3. Volume issue with 1788
    By asianfire in forum Whistler
    Replies: 1
    Last Post: 02-16-2006, 05:03 PM
  4. The Whistler 1788
    By Radar 4 Ever in forum Whistler
    Replies: 3
    Last Post: 02-09-2006, 09:08 PM
  5. Whistler 1788 = SUCKS!
    By k1mri in forum Whistler
    Replies: 3
    Last Post: 02-09-2006, 07:44 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts