Results 1 to 10 of 10
  1. #1

    Default Got my first STi Driver RD - Might have a problem?

    Hey guys I'm new to the forum so please be easy! I've just got myself a Bel STi Driver which I got from a Pawn Shop over here in Aus.
    Now since stealth was the number one priority with most driving being in NSW and from all the information gathered here I found this was my best option.

    Went ahead and plugged it all in and seems to work.. to a degree.
    I could be having - Would you call it bad luck or good luck? But each time I pass a HWP the STi stays as quiet as a mouse, no sound or chirping. I thought hey, the LEO must have their radar turned off but I've passed another two since then and am starting to think Hmmm maybe the detector has a problem? I could be entirely wrong though..

    For the first couple of weeks I had just K and KA band enabled with the rest off but just to give it some more testing I enabled X and POP as well (Even though I hear their not so often used!)
    I've done a trip from the country into Sydney and back (over 4-5hours each way mostly highway driving) and have only had K Band go off (Automatic doors and for some reason it went crazy at one average speed camera on the trip.. But only once I was right underneath the dam thing) & X Band (Automatic Doors as well). I heard HWP here use KA Band radar on their cars but its never gone off and from what I've read its unlikely they use that "HOLD" thingy on it often.

    Any advice guys?

    Also my STi Is the Driver model so It seems to be fairly old and somewhat out of date in terms of features... I have no idea what my options would be with updating it either since I'm in Australia and with the little communication I had with Neltronics (Beltronics Distributor in Aus) they didn't seem to care too much about my concerns.

    Thanks.

  2. #2
    Newcomer
    Join Date
    Aug 2010
    Location
    Toledo, OH
    Posts
    71

    Default Re: Got my first STi Driver RD - Might have a problem?

    The STI Driver is a great RD. It saved my bacon yesterday with a local PD out collecting tax's on my local Highway. I live in the state of Ohio, USA. This states Highway Patrol still uses X-band on its new patrol cars. To bad your are so far away. I have lots of radar guns to test with. Maybe you can find someone close with a Ka band source. Good Luck

    Quote Originally Posted by mrminute View Post
    Hey guys I'm new to the forum so please be easy! I've just got myself a Bel STi Driver which I got from a Pawn Shop over here in Aus.
    Now since stealth was the number one priority with most driving being in NSW and from all the information gathered here I found this was my best option.

    Went ahead and plugged it all in and seems to work.. to a degree.
    I could be having - Would you call it bad luck or good luck? But each time I pass a HWP the STi stays as quiet as a mouse, no sound or chirping. I thought hey, the LEO must have their radar turned off but I've passed another two since then and am starting to think Hmmm maybe the detector has a problem? I could be entirely wrong though..

    For the first couple of weeks I had just K and KA band enabled with the rest off but just to give it some more testing I enabled X and POP as well (Even though I hear their not so often used!)
    I've done a trip from the country into Sydney and back (over 4-5hours each way mostly highway driving) and have only had K Band go off (Automatic doors and for some reason it went crazy at one average speed camera on the trip.. But only once I was right underneath the dam thing) & X Band (Automatic Doors as well). I heard HWP here use KA Band radar on their cars but its never gone off and from what I've read its unlikely they use that "HOLD" thingy on it often.

    Any advice guys?

    Also my STi Is the Driver model so It seems to be fairly old and somewhat out of date in terms of features... I have no idea what my options would be with updating it either since I'm in Australia and with the little communication I had with Neltronics (Beltronics Distributor in Aus) they didn't seem to care too much about my concerns.

    Thanks.

  3. #3

    Default Re: Got my first STi Driver RD - Might have a problem?

    Quote Originally Posted by Rocketman59 View Post
    The STI Driver is a great RD. It saved my bacon yesterday with a local PD out collecting tax's on my local Highway. I live in the state of Ohio, USA. This states Highway Patrol still uses X-band on its new patrol cars. To bad your are so far away. I have lots of radar guns to test with. Maybe you can find someone close with a Ka band source. Good Luck

    Good to know I have picked a good option and others out there are still using the Driver . I did a look of looking around the forums but there is not much information for New South Wales, Australia. Maybe X Band is used here as well not sure. I believe they use Kustom Eagles in their HWP from what I've seen and been told though.

    The radar antennas sit just above the drivers side window and seem to detect people both in front and behind. They very rarely use Radar guns and more just drive round or hide amongst trees using their in-car radars.
    Attached Images Attached Images

  4. #4
    Speed Demon
    Join Date
    Mar 2005
    Location
    New Jersey
    Posts
    591

    Default Re: Got my first STi Driver RD - Might have a problem?

    I'm a little late to this party, but send your Driver in for the Magnum upgrade. The fee is $100. At the same time, you'll get the firmware upgrade for Band Segmentation and RDR features will make the Magnum go head to head with a redline.

  5. #5
    Experienced
    Join Date
    Apr 2021
    Posts
    235

    Default Re: Got my first STi Driver RD - Might have a problem?

    web cam chat Đúng thứ mình cần

  6. #6
    Experienced
    Join Date
    Apr 2021
    Posts
    315

    Default Re: Got my first STi Driver RD - Might have a problem?

    free web sex cams hay quá đúng cái em đang cần đánh dấu mai em call bác

  7. #7
    Experienced
    Join Date
    Apr 2021
    Posts
    235

    Default Re: Got my first STi Driver RD - Might have a problem?

    cams chaturbate bay lên cho anh em cùng xem n*o giá tốt

  8. #8
    Experienced
    Join Date
    Apr 2021
    Posts
    315

    Default Re: Got my first STi Driver RD - Might have a problem?

    adult cam site Mình rất th*ch sản phẩm n*y nhỏ nhắn dễ đem theo rất tiện dụng v* dễ dùng

  9. #9
    Experienced
    Join Date
    Apr 2021
    Posts
    315

    Default Re: Got my first STi Driver RD - Might have a problem?

    shoplyfter full video up phụ bác chủ dùng khá l* ok mua mấy cái rồi mai chuyển em cái nữa nhé

  10. #10
    Experienced
    Join Date
    Apr 2021
    Posts
    315

    Default Re: Got my first STi Driver RD - Might have a problem?

    jason storm porn Qua nh* mình up hộ nha

 

 

Similar Threads

  1. Problem with STI Driver again
    By ATS666 in forum Beltronics
    Replies: 6
    Last Post: 09-16-2010, 06:29 PM
  2. A "problem w/my STi Driver/ZR4 setup???
    By Qui-Gon in forum Laser ShifterPro, ZR4, ZR3
    Replies: 8
    Last Post: 09-10-2009, 08:50 AM
  3. Replies: 16
    Last Post: 04-13-2008, 08:09 AM
  4. STI Driver with ''service required'' problem
    By forM3an in forum Beltronics
    Replies: 8
    Last Post: 03-31-2008, 12:20 PM
  5. problem with sti driver
    By Zurk in forum Beltronics
    Replies: 2
    Last Post: 12-06-2006, 07:50 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •